aboutsummaryrefslogtreecommitdiff
path: root/net-im/nheko
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-07-13 12:39:07 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-07-13 12:39:07 +0000
commitcb107b54fb0a86673b7e103ec063842ab6bb2e9c (patch)
tree65e160d8c4fb4122e6ea480213c64c6cb5340dfa /net-im/nheko
parentf1334eb2cb1d01cc6344e6e90ce6d14a61ee11be (diff)
Notes
Diffstat (limited to 'net-im/nheko')
-rw-r--r--net-im/nheko/files/patch-CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/net-im/nheko/files/patch-CMakeLists.txt b/net-im/nheko/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..469bc6fcac7e
--- /dev/null
+++ b/net-im/nheko/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2019-07-13 12:11:29 UTC
++++ CMakeLists.txt
+@@ -114,6 +114,9 @@ if(NOT MSVC)
+ endif()
+ endif()
+
++# Fix build with Qt 5.13
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_DEPRECATED_WARNINGS=Y")
++
+ if (MSVC)
+ set(
+ CMAKE_CXX_FLAGS