aboutsummaryrefslogtreecommitdiff
path: root/net-im/ocaml-jabbr/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:05:52 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:05:52 +0000
commit733134ead73b8ab0e19b1f9c7b6a7723568f89c8 (patch)
treeeb6f67dfe4f463463802ac10126996580cc03aa1 /net-im/ocaml-jabbr/Makefile
parent5dace82881ebf62aedc57d07ec76b50b37ee743e (diff)
downloadports-733134ead73b8ab0e19b1f9c7b6a7723568f89c8.tar.gz
ports-733134ead73b8ab0e19b1f9c7b6a7723568f89c8.zip
Notes
Diffstat (limited to 'net-im/ocaml-jabbr/Makefile')
-rw-r--r--net-im/ocaml-jabbr/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-im/ocaml-jabbr/Makefile b/net-im/ocaml-jabbr/Makefile
new file mode 100644
index 000000000000..32ef8badbede
--- /dev/null
+++ b/net-im/ocaml-jabbr/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ocaml jabbr
+# Date created: Thu Jan 9 05:59:43 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jabbr
+PORTVERSION= 0.0.${DATE_VERSION}
+CATEGORIES= net
+MASTER_SITES= http://mikelin.mit.edu/xmpp/jabbr/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= jabbr
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
+ ${LOCALBASE}/lib/ocaml/yaxpo.cma:${PORTSDIR}/textproc/ocaml-yaxpo
+
+# depend when building as well
+BUILD_DEPENDS+= ${RUN_DEPENDS}
+
+USE_REINPLACE= yes
+
+DATE_VERSION= 20021124
+
+post-configure:
+# PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|' \
+ ${WRKSRC}/Makefile
+
+post-build:
+.ifndef(NOPORTDOCS)
+ @cd ${WRKSRC} && ${MAKE} doc
+.endif
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp -f |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>