aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-XMPP2
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net-im/p5-Net-XMPP2
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'net-im/p5-Net-XMPP2')
-rw-r--r--net-im/p5-Net-XMPP2/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/net-im/p5-Net-XMPP2/Makefile b/net-im/p5-Net-XMPP2/Makefile
index 1f9b916f396c..f00a5fecfc7e 100644
--- a/net-im/p5-Net-XMPP2/Makefile
+++ b/net-im/p5-Net-XMPP2/Makefile
@@ -22,16 +22,7 @@ BUILD_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
p5-Object-Event>=0:${PORTSDIR}/devel/p5-Object-Event \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
-RUN_DEPENDS:= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
- p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
- p5-BS-Event>=0:${PORTSDIR}/devel/p5-BS-Event \
- p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
- p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
- p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN \
- p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
- p5-Object-Event>=0:${PORTSDIR}/devel/p5-Object-Event \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure