aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-XMPP
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /net-im/p5-Net-XMPP
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Notes
Notes: svn path=/head/; revision=199069
Diffstat (limited to 'net-im/p5-Net-XMPP')
-rw-r--r--net-im/p5-Net-XMPP/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
index 7540eb255f67..a678de7b08f4 100644
--- a/net-im/p5-Net-XMPP/Makefile
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+ # Require perl 5.8.x due to XML::Stream
MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \
@@ -28,11 +28,4 @@ MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
Net::XMPP::Protocol.3 Net::XMPP::Roster.3 \
Net::XMPP::Stanza.3
-.include <bsd.port.pre.mk>
-
-# Require perl 5.8.x due to XML::Stream
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>