aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Protocol-XMPP
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-07 15:37:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-07 15:37:52 +0000
commit795ce42418ac6201834214a3fa9ff61a8991cb73 (patch)
treeea7a8fa57de0208911d1d5c5420f0cd623220ecc /net-im/p5-Protocol-XMPP
parent1381ab169fdae7854836e89afe19355692bd8e15 (diff)
downloadports-795ce42418ac6201834214a3fa9ff61a8991cb73.tar.gz
ports-795ce42418ac6201834214a3fa9ff61a8991cb73.zip
- Add p5-Protocol-XMPP 0.005
Protocol::XMPP provides an API for the Extensible Message Passing Protocol. This is commonly used for integration with Jabber servers and Google Talk, although XMPP itself supports a number of extended features for a distributed multi-server, multi-client message exchange system. WWW: http://search.cpan.org/dist/Protocol-XMPP/ PR: ports/155341 Submitted by: "ports@c0decafe.net" <ports@c0decafe.net>
Notes
Notes: svn path=/head/; revision=270450
Diffstat (limited to 'net-im/p5-Protocol-XMPP')
-rw-r--r--net-im/p5-Protocol-XMPP/Makefile58
-rw-r--r--net-im/p5-Protocol-XMPP/distinfo2
-rw-r--r--net-im/p5-Protocol-XMPP/pkg-descr6
-rw-r--r--net-im/p5-Protocol-XMPP/pkg-plist40
4 files changed, 106 insertions, 0 deletions
diff --git a/net-im/p5-Protocol-XMPP/Makefile b/net-im/p5-Protocol-XMPP/Makefile
new file mode 100644
index 000000000000..e9a3ee2520c9
--- /dev/null
+++ b/net-im/p5-Protocol-XMPP/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: p5-Protocol-XMPP
+# Date created: 2011-03-07
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Protocol-XMPP
+PORTVERSION= 0.005
+CATEGORIES= net-im perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TEAM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Protocol-level support for XMPP interaction
+
+RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-Module-Load>=0:${PORTSDIR}/devel/p5-Module-Load \
+ p5-XML-LibXML-SAX-ChunkParser>=0.00003:${PORTSDIR}/textproc/p5-XML-LibXML-SAX-ChunkParser \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+
+PERL_CONFIGURE= yes
+
+MAN3= Protocol::XMPP.3 \
+ Protocol::XMPP::Base.3 \
+ Protocol::XMPP::Contact.3 \
+ Protocol::XMPP::Element::Active.3 \
+ Protocol::XMPP::Element::Auth.3 \
+ Protocol::XMPP::Element::Bind.3 \
+ Protocol::XMPP::Element::Body.3 \
+ Protocol::XMPP::Element::Challenge.3 \
+ Protocol::XMPP::Element::Feature.3 \
+ Protocol::XMPP::Element::Features.3 \
+ Protocol::XMPP::Element::HTML.3 \
+ Protocol::XMPP::Element::IQ.3 \
+ Protocol::XMPP::Element::JID.3 \
+ Protocol::XMPP::Element::Mechanism.3 \
+ Protocol::XMPP::Element::Mechanisms.3 \
+ Protocol::XMPP::Element::Message.3 \
+ Protocol::XMPP::Element::Nick.3 \
+ Protocol::XMPP::Element::Presence.3 \
+ Protocol::XMPP::Element::Proceed.3 \
+ Protocol::XMPP::Element::Register.3 \
+ Protocol::XMPP::Element::Response.3 \
+ Protocol::XMPP::Element::Session.3 \
+ Protocol::XMPP::Element::StartTLS.3 \
+ Protocol::XMPP::Element::Subject.3 \
+ Protocol::XMPP::Element::Success.3 \
+ Protocol::XMPP::ElementBase.3 \
+ Protocol::XMPP::Handler.3 \
+ Protocol::XMPP::IQ::Roster.3 \
+ Protocol::XMPP::Message.3 \
+ Protocol::XMPP::Stream.3 \
+ Protocol::XMPP::TextElement.3 \
+ Protocol::XMPP::User.3
+
+.include <bsd.port.mk>
diff --git a/net-im/p5-Protocol-XMPP/distinfo b/net-im/p5-Protocol-XMPP/distinfo
new file mode 100644
index 000000000000..7baf63eb432e
--- /dev/null
+++ b/net-im/p5-Protocol-XMPP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Protocol-XMPP-0.005.tar.gz) = cfba6257c0d44debc9605dd89f58d3edea15309bdc154038e00f7d98bdc1a221
+SIZE (Protocol-XMPP-0.005.tar.gz) = 18955
diff --git a/net-im/p5-Protocol-XMPP/pkg-descr b/net-im/p5-Protocol-XMPP/pkg-descr
new file mode 100644
index 000000000000..15d42c02a742
--- /dev/null
+++ b/net-im/p5-Protocol-XMPP/pkg-descr
@@ -0,0 +1,6 @@
+Protocol::XMPP provides an API for the Extensible Message Passing Protocol.
+This is commonly used for integration with Jabber servers and Google Talk,
+although XMPP itself supports a number of extended features for a distributed
+multi-server, multi-client message exchange system.
+
+WWW: http://search.cpan.org/dist/Protocol-XMPP/
diff --git a/net-im/p5-Protocol-XMPP/pkg-plist b/net-im/p5-Protocol-XMPP/pkg-plist
new file mode 100644
index 000000000000..a0fdb4ecdf8d
--- /dev/null
+++ b/net-im/p5-Protocol-XMPP/pkg-plist
@@ -0,0 +1,40 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Protocol/XMPP.pm
+%%SITE_PERL%%/Protocol/XMPP/Base.pm
+%%SITE_PERL%%/Protocol/XMPP/Contact.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Active.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Auth.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Bind.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Body.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Challenge.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Feature.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Features.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/HTML.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/IQ.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/JID.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Mechanism.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Mechanisms.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Message.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Nick.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Presence.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Proceed.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Register.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Response.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Session.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/StartTLS.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Subject.pm
+%%SITE_PERL%%/Protocol/XMPP/Element/Success.pm
+%%SITE_PERL%%/Protocol/XMPP/ElementBase.pm
+%%SITE_PERL%%/Protocol/XMPP/Handler.pm
+%%SITE_PERL%%/Protocol/XMPP/IQ/Roster.pm
+%%SITE_PERL%%/Protocol/XMPP/Message.pm
+%%SITE_PERL%%/Protocol/XMPP/Stream.pm
+%%SITE_PERL%%/Protocol/XMPP/TextElement.pm
+%%SITE_PERL%%/Protocol/XMPP/User.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/XMPP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/XMPP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol
+@dirrmtry %%SITE_PERL%%/Protocol/XMPP/IQ
+@dirrmtry %%SITE_PERL%%/Protocol/XMPP/Element
+@dirrmtry %%SITE_PERL%%/Protocol/XMPP
+@dirrmtry %%SITE_PERL%%/Protocol