aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-latex
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-06-23 10:15:55 +0000
committerSimon Barner <barner@FreeBSD.org>2005-06-23 10:15:55 +0000
commitd1aec85f9aa5d690cc5ebb78d3ac746860903222 (patch)
treea1b42674e67f5b91cd0c1cd020bb88be603d01e7 /net-im/pidgin-latex
parent4726b54ea89afe9a4a5c778924d971b3ff7bde47 (diff)
downloadports-d1aec85f9aa5d690cc5ebb78d3ac746860903222.tar.gz
ports-d1aec85f9aa5d690cc5ebb78d3ac746860903222.zip
Add gaim-latex 0.3, a gaim plugin to display LaTeX output in your IMs.
PR: 82542 Submitted by: Geoffrey Mainland <mainland@apeiron.net>
Notes
Notes: svn path=/head/; revision=137916
Diffstat (limited to 'net-im/pidgin-latex')
-rw-r--r--net-im/pidgin-latex/Makefile34
-rw-r--r--net-im/pidgin-latex/distinfo2
-rw-r--r--net-im/pidgin-latex/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/net-im/pidgin-latex/Makefile b/net-im/pidgin-latex/Makefile
new file mode 100644
index 000000000000..cb82d54ff714
--- /dev/null
+++ b/net-im/pidgin-latex/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Gaim-LaTeX
+# Date created: 2005-06-22
+# Whom: Geoffrey Mainland <mainland@apeiron.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latex
+PORTVERSION= 0.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+PKGNAMEPREFIX= gaim-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mainland@apeiron.net
+COMMENT= Display LaTeX output in your IMs
+
+BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim
+RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim \
+ latex:${PORTSDIR}/print/teTeX \
+ convert:${PORTSDIR}/graphics/ImageMagick
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_BZIP2= yes
+
+PLIST_FILES= lib/gaim/LaTeX.so
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/gaim
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-latex/distinfo b/net-im/pidgin-latex/distinfo
new file mode 100644
index 000000000000..5ae7a50f84b5
--- /dev/null
+++ b/net-im/pidgin-latex/distinfo
@@ -0,0 +1,2 @@
+MD5 (gaim-latex-0.3.tar.bz2) = e0ff7686b3e40a8f2e456785b0557a29
+SIZE (gaim-latex-0.3.tar.bz2) = 12903
diff --git a/net-im/pidgin-latex/pkg-descr b/net-im/pidgin-latex/pkg-descr
new file mode 100644
index 000000000000..46c46e0e7ddb
--- /dev/null
+++ b/net-im/pidgin-latex/pkg-descr
@@ -0,0 +1,4 @@
+This is a plugin for Gaim that allows you to display LaTeX output in
+your IMs.
+
+WWW: http://sourceforge.net/projects/gaim-latex