aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-libnotify
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-15 21:35:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-15 21:35:33 +0000
commitec93b6aea2adb9eb1bddc97fcd461be951989e47 (patch)
tree89f725791d42446f13b238f6190523fdc8dd6b4d /net-im/pidgin-libnotify
parentd8c97d05f27ff4e9a396b4d541a82e5d15f21277 (diff)
downloadports-ec93b6aea2adb9eb1bddc97fcd461be951989e47.tar.gz
ports-ec93b6aea2adb9eb1bddc97fcd461be951989e47.zip
This plugin adds a libnotify interface to pidgin, enabling popups much like
guifications. It has some configuration options, to show popups when a buddy signs on, on new messages and on new conversations only. WWW: http://gaim-libnotify.sourceforge.net/ PR: ports/114479 Submitted by: Meethune Bhowmick <meethune at gmail.com>
Notes
Notes: svn path=/head/; revision=195685
Diffstat (limited to 'net-im/pidgin-libnotify')
-rw-r--r--net-im/pidgin-libnotify/Makefile44
-rw-r--r--net-im/pidgin-libnotify/distinfo3
-rw-r--r--net-im/pidgin-libnotify/pkg-descr8
-rw-r--r--net-im/pidgin-libnotify/pkg-plist14
4 files changed, 69 insertions, 0 deletions
diff --git a/net-im/pidgin-libnotify/Makefile b/net-im/pidgin-libnotify/Makefile
new file mode 100644
index 000000000000..98c7c9ff3212
--- /dev/null
+++ b/net-im/pidgin-libnotify/Makefile
@@ -0,0 +1,44 @@
+# Ports collection Makefile for: pidgin-libnotify
+# Date created: 2007-07-10
+# Whom: Meethune Bhowmick <meethune@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnotify
+PORTVERSION= 0.13
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S^%SUBDIR%^gaim-libnotify^}
+PKGNAMEPREFIX= pidgin-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= meethune@gmail.com
+COMMENT= This plugin adds a libnotify interface to Pidgin
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin \
+ ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+ purple.0:${PORTSDIR}/net-im/libpurple
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig gtk20
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+CONFIGURE_ARGS= --disable-static
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-libnotify/distinfo b/net-im/pidgin-libnotify/distinfo
new file mode 100644
index 000000000000..cbd457e55907
--- /dev/null
+++ b/net-im/pidgin-libnotify/distinfo
@@ -0,0 +1,3 @@
+MD5 (pidgin-libnotify-0.13.tar.gz) = cb71adcb3aa116b6480281e211e61fda
+SHA256 (pidgin-libnotify-0.13.tar.gz) = 2a2aa46f23fac202bb23c2a7bb297576e8e43a0dac7ca67cf5363eb489d24593
+SIZE (pidgin-libnotify-0.13.tar.gz) = 356042
diff --git a/net-im/pidgin-libnotify/pkg-descr b/net-im/pidgin-libnotify/pkg-descr
new file mode 100644
index 000000000000..e4db211263eb
--- /dev/null
+++ b/net-im/pidgin-libnotify/pkg-descr
@@ -0,0 +1,8 @@
+This plugin adds a libnotify interface to pidgin, enabling popups much like
+guifications. It has some configuration options, to show popups when a buddy
+signs on, on new messages and on new conversations only.
+
+WWW: http://gaim-libnotify.sourceforge.net/
+
+- Meethune Bhowmick
+meethune@gmail.com
diff --git a/net-im/pidgin-libnotify/pkg-plist b/net-im/pidgin-libnotify/pkg-plist
new file mode 100644
index 000000000000..9aead91dc11b
--- /dev/null
+++ b/net-im/pidgin-libnotify/pkg-plist
@@ -0,0 +1,14 @@
+%%NLS%%share/locale/es/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/pidgin-libnotify.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/pidgin-libnotify.mo
+lib/purple-2/pidgin-libnotify.so
+lib/purple-2/pidgin-libnotify.la