aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-skypeweb/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-18 13:52:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-18 13:52:18 +0000
commit368261eea5aaa189d17acfc40a6a88691defd8ad (patch)
tree402b54da0b3d84d81a5b634ccd18a4be163bd51a /net-im/pidgin-skypeweb/Makefile
parentd79529d792fe31cc540b3b0734d593bf22a37a89 (diff)
downloadports-368261eea5aaa189d17acfc40a6a88691defd8ad.tar.gz
ports-368261eea5aaa189d17acfc40a6a88691defd8ad.zip
Notes
Diffstat (limited to 'net-im/pidgin-skypeweb/Makefile')
-rw-r--r--net-im/pidgin-skypeweb/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/pidgin-skypeweb/Makefile b/net-im/pidgin-skypeweb/Makefile
new file mode 100644
index 000000000000..57b69af97b20
--- /dev/null
+++ b/net-im/pidgin-skypeweb/Makefile
@@ -0,0 +1,42 @@
+# Created by: Andrey Akhmichin <sepulkarium45@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= pidgin-skypeweb
+PORTVERSION= 08222015
+CATEGORIES= net-im
+
+MAINTAINER= sepulkarium45@yahoo.com
+COMMENT= Plugin to use Skype chat from Pidgin(without Skype running)
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/gpl3.txt
+
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
+
+USE_GITHUB= yes
+GH_ACCOUNT= EionRobb
+GH_PROJECT= skype4pidgin
+GH_TAGNAME= 08cbc21
+
+USES= gmake pkgconfig
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+CONFLICTS_INSTALL= pidgin-skype-*
+WRKSRC_SUBDIR= skypeweb
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/purple-2
+ ${INSTALL_PROGRAM} ${WRKSRC}/libskypeweb.so ${STAGEDIR}${PREFIX}/lib/purple-2
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/emotes/skype
+ ${INSTALL_DATA} ${WRKSRC}/theme ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/emotes/skype
+.for i in 16 22 48
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/protocols/${i}
+ ${INSTALL_DATA} ${WRKSRC}/icons/${i}/skypeout.png \
+ ${WRKSRC}/icons/${i}/skype.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/protocols/${i}/
+.endfor
+
+.include <bsd.port.mk>