aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-fbmq/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2016-08-29 15:54:30 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2016-08-29 15:54:30 +0000
commitfa3ad7a6db45d86754c82671540ffee59bbc8971 (patch)
tree3f76322ede4c5c4465e558eb6b4c382e17a9219e /net-im/py-fbmq/Makefile
parentd732ee9b491056ed87c43bf8611940c7b85ab1e4 (diff)
downloadports-fa3ad7a6db45d86754c82671540ffee59bbc8971.tar.gz
ports-fa3ad7a6db45d86754c82671540ffee59bbc8971.zip
Notes
Diffstat (limited to 'net-im/py-fbmq/Makefile')
-rw-r--r--net-im/py-fbmq/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-im/py-fbmq/Makefile b/net-im/py-fbmq/Makefile
new file mode 100644
index 000000000000..024b92afa486
--- /dev/null
+++ b/net-im/py-fbmq/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= fbmq
+PORTVERSION= 1.7.0
+CATEGORIES= net-im devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Python library for using the Facebook Messenger API
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>