aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-nbxmpp
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-10-05 17:11:04 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-10-05 17:11:04 +0000
commit74d5bf79ed2d38773ca93f0718d83086f04db284 (patch)
treef26677b1832ec69fc57c9a282851c55165b69f15 /net-im/py-nbxmpp
parent13b30d27b83b9377fce371e41e17e20bd24c76c2 (diff)
downloadports-74d5bf79ed2d38773ca93f0718d83086f04db284.tar.gz
ports-74d5bf79ed2d38773ca93f0718d83086f04db284.zip
The goal of this python library is to provide a way for python applications
to use Jabber/XMPP networks in a non-blocking way. This library is initialy a fork of xmpppy one, but using non-blocking sockets. WWW: https://python-nbxmpp.gajim.org/
Notes
Notes: svn path=/head/; revision=370096
Diffstat (limited to 'net-im/py-nbxmpp')
-rw-r--r--net-im/py-nbxmpp/Makefile21
-rw-r--r--net-im/py-nbxmpp/distinfo2
-rw-r--r--net-im/py-nbxmpp/pkg-descr5
3 files changed, 28 insertions, 0 deletions
diff --git a/net-im/py-nbxmpp/Makefile b/net-im/py-nbxmpp/Makefile
new file mode 100644
index 000000000000..9dcbe83d5af5
--- /dev/null
+++ b/net-im/py-nbxmpp/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= nbxmpp
+PORTVERSION= 0.5.1
+CATEGORIES= net-im devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Non blocking Jabber/XMPP module
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:${PORTSDIR}/devel/py-zope.interface
+
+USES= python twisted:run
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net-im/py-nbxmpp/distinfo b/net-im/py-nbxmpp/distinfo
new file mode 100644
index 000000000000..e250f4311cea
--- /dev/null
+++ b/net-im/py-nbxmpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nbxmpp-0.5.1.tar.gz) = fa312db1e912434b60545e6ccd64edb54d00f8afcc04e84d9ffa16e8cbf17ba5
+SIZE (nbxmpp-0.5.1.tar.gz) = 1514900
diff --git a/net-im/py-nbxmpp/pkg-descr b/net-im/py-nbxmpp/pkg-descr
new file mode 100644
index 000000000000..ca900be89b0e
--- /dev/null
+++ b/net-im/py-nbxmpp/pkg-descr
@@ -0,0 +1,5 @@
+The goal of this python library is to provide a way for python applications
+to use Jabber/XMPP networks in a non-blocking way. This library is initialy a
+fork of xmpppy one, but using non-blocking sockets.
+
+WWW: https://python-nbxmpp.gajim.org/