aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-slixmpp
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-01-08 13:31:14 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-01-08 13:31:14 +0000
commit7452f2e01868cb3b0229e8f06ad17e298576ca27 (patch)
treee872855674dc091e6ae5e3fa6bdf9202cd023e99 /net-im/py-slixmpp
parent28aa1641bcdd6546edf48165f0620f341a44e47c (diff)
downloadports-7452f2e01868cb3b0229e8f06ad17e298576ca27.tar.gz
ports-7452f2e01868cb3b0229e8f06ad17e298576ca27.zip
net-im/py-slixmpp: Add missing RUN_DEPENDS and fix some other issues
- Switch MASTER_SITES to CHEESESHOP as it ought to be the default for Python software. - Adjust COMMENT to match the short description from setup.py. - Add missing RUN_DEPENDS. - Standardize test invocation. - Update WWW to point to project's homepage instead of the Git repository. Reported by: koobs Reviewed by: koobs, krion Approved by: koobs, krion (mentor) Differential Revision: https://reviews.freebsd.org/D18684
Notes
Notes: svn path=/head/; revision=489686
Diffstat (limited to 'net-im/py-slixmpp')
-rw-r--r--net-im/py-slixmpp/Makefile14
-rw-r--r--net-im/py-slixmpp/distinfo6
-rw-r--r--net-im/py-slixmpp/pkg-descr2
3 files changed, 13 insertions, 9 deletions
diff --git a/net-im/py-slixmpp/Makefile b/net-im/py-slixmpp/Makefile
index 012435fb0da2..d4f98286cd9f 100644
--- a/net-im/py-slixmpp/Makefile
+++ b/net-im/py-slixmpp/Makefile
@@ -2,26 +2,30 @@
PORTNAME= slixmpp
DISTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= net-im python
-MASTER_SITES= https://git.poez.io/slixmpp/snapshot/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= slix-${DISTVERSION}
MAINTAINER= 0mp@FreeBSD.org
-COMMENT= Threadless Poezio-oriented fork of SleekXMPP using asyncio
+COMMENT= Elegant Python library for XMPP (aka Jabber, Google Talk, etc.)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libidn.so:dns/libidn
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0:devel/py-pyasn1-modules@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}aiodns>=1.0:dns/py-aiodns@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR}
TEST_DEPENDS= gpg:security/gnupg
-USES= python:3.5+
+USES= pkgconfig python:3.5+
USE_PYTHON= distutils autoplist cython
NO_ARCH= yes
do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/net-im/py-slixmpp/distinfo b/net-im/py-slixmpp/distinfo
index a8c5bbee0fd0..3ecd0e28ac31 100644
--- a/net-im/py-slixmpp/distinfo
+++ b/net-im/py-slixmpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545919194
-SHA256 (slix-1.4.1.tar.gz) = 2ae5755c9d593d5e2e31985dffe4829670d947273f78a7a34ec263617eece0d6
-SIZE (slix-1.4.1.tar.gz) = 1009754
+TIMESTAMP = 1546111826
+SHA256 (slixmpp-1.4.1.tar.gz) = 020acd4507fd00c38835b78b5f338db60d3df840187623e0d41ab2ca89d7ae57
+SIZE (slixmpp-1.4.1.tar.gz) = 862964
diff --git a/net-im/py-slixmpp/pkg-descr b/net-im/py-slixmpp/pkg-descr
index 5a474ccac990..6413e228ccb7 100644
--- a/net-im/py-slixmpp/pkg-descr
+++ b/net-im/py-slixmpp/pkg-descr
@@ -5,4 +5,4 @@ Slixmpp's goals is to only rewrite the core of the library (the low level
socket handling, the timers, the events dispatching) in order to remove all
threads.
-WWW: https://git.poez.io/slixmpp/
+WWW: https://dev.louiz.org/projects/slixmpp