aboutsummaryrefslogtreecommitdiff
path: root/net-im/qTox
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-10-21 09:39:18 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-10-21 09:39:18 +0000
commit6c81eb9a2c43bd69950b176b1a8c924917f2f8f7 (patch)
tree3b30af37ccb7d2be5c9d731855dd5c6a44f8bc22 /net-im/qTox
parentaa29135563d587ac5f182223e54cc3b1002d0a23 (diff)
downloadports-6c81eb9a2c43bd69950b176b1a8c924917f2f8f7.tar.gz
ports-6c81eb9a2c43bd69950b176b1a8c924917f2f8f7.zip
Notes
Diffstat (limited to 'net-im/qTox')
-rw-r--r--net-im/qTox/Makefile41
-rw-r--r--net-im/qTox/distinfo6
-rw-r--r--net-im/qTox/pkg-message (renamed from net-im/qTox/files/pkg-message.in)0
3 files changed, 19 insertions, 28 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index 8acdfd5db427..9eca24e6db9c 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,15 +2,15 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 1.11.0
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+DISTVERSION= 1.12.1
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@rawbw.com
COMMENT= Qt 5 based Tox client
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libtoxcore.so:net-im/tox \
@@ -26,29 +26,32 @@ LIB_DEPENDS= libtoxcore.so:net-im/tox \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
+OPTIONS_DEFINE= PLATFORM_EXTENSIONS
+OPTIONS_DEFAULT=PLATFORM_EXTENSIONS
+PLATFORM_EXTENSIONS_DESC= Enable platform specific extensions
+
USE_GITHUB= yes
GH_ACCOUNT= qTox
-
-SUB_FILES= pkg-message
+GH_TAGNAME= cd8a7ad
USES= compiler:c++11-lib desktop-file-utils gettext openal:soft pkgconfig cmake
-USE_GNOME= glib20 gtk20 cairo gdkpixbuf2
-USE_XORG= x11 xscrnsaver
-USE_GL= gl
-USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets svg testlib \
- concurrent buildtools_build linguisttools_build
-# bug#220813: qmake isn't needed, but the build fails without qmake_build
+USE_GNOME= gtk20 cairo
+USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets svg \
+ concurrent_build buildtools_build linguisttools_build testlib_build
+# bug#220813: qmake isn't needed, but build fails without qmake_build
USE_QT5+= qmake_build
CMAKE_ARGS= -DGIT_DESCRIBE:STRING=${FULLVERSION}
INSTALLS_ICONS= yes
-ICON_SIZES= 14x14 16x16 22x22 24x24 32x32 36x36 48x48 64x64 72x72 96x96 128x128 192x192 256x256 512x512
+
+PLATFORM_EXTENSIONS_CMAKE_OFF= -DPLATFORM_EXTENSIONS:BOOL=OFF
+PLATFORM_EXTENSIONS_USE= XORG=x11,xscrnsaver
PLIST_FILES= bin/qtox \
share/applications/qtox.desktop \
share/icons/hicolor/scalable/apps/qtox.svgz \
share/appdata/qTox.appdata.xml
-.for SZ in ${ICON_SIZES}
-PLIST_FILES+= share/icons/hicolor/${SZ}/apps/qtox.png
+.for SZ in 14 16 22 24 32 36 48 64 72 96 128 192 256 512
+PLIST_FILES+= share/icons/hicolor/${SZ}x${SZ}/apps/qtox.png
.endfor
.include <bsd.port.pre.mk>
@@ -73,16 +76,4 @@ pre-configure:
@${REINPLACE_CMD} '/Comment/s,=.*,=${COMMENT},' \
${WRKSRC}/qtox.desktop
-post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
- @${GZIP_CMD} \
- < ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/qtox.svg \
- > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/qtox.svgz
- @${RM} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/qtox.svg
-.for SZ in ${ICON_SIZES}
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps
- ${INSTALL_DATA} ${WRKSRC}/img/icons/${SZ}/qtox.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
-.endfor
-
.include <bsd.port.post.mk>
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index 30d95b4444e2..4d7cb02a80d6 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500321399
-SHA256 (qTox-qTox-v1.11.0_GH0.tar.gz) = be38517cd915727dbd9b3cd2a51bbaf1cae28290de07a34c759ec8b77c502cd4
-SIZE (qTox-qTox-v1.11.0_GH0.tar.gz) = 3946782
+TIMESTAMP = 1507800999
+SHA256 (qTox-qTox-v1.12.1-cd8a7ad_GH0.tar.gz) = 90709402c93f6529d88c05ff106072e3e4e42ac06917d7b955f3ae39813c13dd
+SIZE (qTox-qTox-v1.12.1-cd8a7ad_GH0.tar.gz) = 3957662
diff --git a/net-im/qTox/files/pkg-message.in b/net-im/qTox/pkg-message
index 2eb416388d72..2eb416388d72 100644
--- a/net-im/qTox/files/pkg-message.in
+++ b/net-im/qTox/pkg-message