aboutsummaryrefslogtreecommitdiff
path: root/net-im/qxmpp
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-02-25 11:33:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-05-26 10:06:27 +0000
commit17fcec77c2e27237305585785dd2ae2ff000b599 (patch)
treec9c04465328058417f8bf551d32c512144c8f1d8 /net-im/qxmpp
parentbb1a46a668cb5078e25dd9eab980e59837196a84 (diff)
downloadports-17fcec77c2e27237305585785dd2ae2ff000b599.tar.gz
ports-17fcec77c2e27237305585785dd2ae2ff000b599.zip
Diffstat (limited to 'net-im/qxmpp')
-rw-r--r--net-im/qxmpp/Makefile36
-rw-r--r--net-im/qxmpp/distinfo3
-rw-r--r--net-im/qxmpp/pkg-descr8
-rw-r--r--net-im/qxmpp/pkg-plist153
4 files changed, 200 insertions, 0 deletions
diff --git a/net-im/qxmpp/Makefile b/net-im/qxmpp/Makefile
new file mode 100644
index 000000000000..01f3d9d9e1d7
--- /dev/null
+++ b/net-im/qxmpp/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= qxmpp
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.5
+CATEGORIES= net-im
+PKGNAMESUFFIX= -${FLAVOR}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= XMPP client library based on Qt and C++
+WWW= https://github.com/qxmpp-project/qxmpp/
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+
+LIB_DEPENDS= libomemo-c.so:security/libomemo-c
+
+FLAVORS= qt5 qt6
+FLAVOR?= qt5
+
+USES= cmake compiler:c++17-lang libtool pathfix pkgconfig qca qt:${FLAVOR:S/qt//}
+USE_GITHUB= yes
+GH_ACCOUNT= qxmpp-project
+USE_QT= ${_USE_QT_${FLAVOR}}
+CMAKE_ARGS= -DQT_VERSION_MAJOR=${FLAVOR:S/qt//}
+CMAKE_ON= BUILD_OMEMO
+
+_USE_QT_qt5= core gui network xml \
+ buildtools:build qmake:build testlib:build
+_USE_QT_qt6= base
+
+_PLIST_QT5_qt5=
+_PLIST_QT5_qt6= "@comment "
+PLIST_SUB= VERSION=${PORTVERSION} \
+ QT_VER=${FLAVOR:S/qt//} \
+ QT5_ONLY=${_PLIST_QT5_${FLAVOR}}
+
+.include <bsd.port.mk>
diff --git a/net-im/qxmpp/distinfo b/net-im/qxmpp/distinfo
new file mode 100644
index 000000000000..144bbc286312
--- /dev/null
+++ b/net-im/qxmpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685076678
+SHA256 (qxmpp-project-qxmpp-v1.5.5_GH0.tar.gz) = b25fba89432c4fd72489d1844f683bfbf4e5aa4cfcfda7a982d6019f8e4529f8
+SIZE (qxmpp-project-qxmpp-v1.5.5_GH0.tar.gz) = 606405
diff --git a/net-im/qxmpp/pkg-descr b/net-im/qxmpp/pkg-descr
new file mode 100644
index 000000000000..8ffc71a17663
--- /dev/null
+++ b/net-im/qxmpp/pkg-descr
@@ -0,0 +1,8 @@
+QXmpp is pretty intuitive and easy to use. It uses Qt extensively.
+Qt is the only third party library it is dependent on. Users need
+to a have working knowledge of C++ and Qt basics (Signals and Slots
+and Qt data types). The underlying TCP socket and the XMPP RFCs
+(RFC3920 and RFC3921) have been encapsulated into classes and
+functions. Therefore the user would not be bothered with these
+details. But it is always recommended to the advanced users to read
+and enjoy the low level details.
diff --git a/net-im/qxmpp/pkg-plist b/net-im/qxmpp/pkg-plist
new file mode 100644
index 000000000000..46310e3379c2
--- /dev/null
+++ b/net-im/qxmpp/pkg-plist
@@ -0,0 +1,153 @@
+include/QXmppQt%%QT_VER%%/Omemo/QXmppOmemoManager.h
+include/QXmppQt%%QT_VER%%/Omemo/QXmppOmemoMemoryStorage.h
+include/QXmppQt%%QT_VER%%/Omemo/QXmppOmemoStorage.h
+include/QXmppQt%%QT_VER%%/Omemo/qxmppomemo_export.h
+include/QXmppQt%%QT_VER%%/QXmppArchiveIq.h
+include/QXmppQt%%QT_VER%%/QXmppArchiveManager.h
+include/QXmppQt%%QT_VER%%/QXmppAtmManager.h
+include/QXmppQt%%QT_VER%%/QXmppAtmTrustMemoryStorage.h
+include/QXmppQt%%QT_VER%%/QXmppAtmTrustStorage.h
+include/QXmppQt%%QT_VER%%/QXmppAttentionManager.h
+include/QXmppQt%%QT_VER%%/QXmppBindIq.h
+include/QXmppQt%%QT_VER%%/QXmppBitsOfBinaryContentId.h
+include/QXmppQt%%QT_VER%%/QXmppBitsOfBinaryData.h
+include/QXmppQt%%QT_VER%%/QXmppBitsOfBinaryDataList.h
+include/QXmppQt%%QT_VER%%/QXmppBitsOfBinaryIq.h
+include/QXmppQt%%QT_VER%%/QXmppBookmarkManager.h
+include/QXmppQt%%QT_VER%%/QXmppBookmarkSet.h
+include/QXmppQt%%QT_VER%%/QXmppByteStreamIq.h
+include/QXmppQt%%QT_VER%%/QXmppCarbonManager.h
+include/QXmppQt%%QT_VER%%/QXmppCarbonManagerV2.h
+include/QXmppQt%%QT_VER%%/QXmppClient.h
+include/QXmppQt%%QT_VER%%/QXmppClientExtension.h
+include/QXmppQt%%QT_VER%%/QXmppConfiguration.h
+include/QXmppQt%%QT_VER%%/QXmppDataForm.h
+include/QXmppQt%%QT_VER%%/QXmppDataFormBase.h
+include/QXmppQt%%QT_VER%%/QXmppDialback.h
+include/QXmppQt%%QT_VER%%/QXmppDiscoveryIq.h
+include/QXmppQt%%QT_VER%%/QXmppDiscoveryManager.h
+include/QXmppQt%%QT_VER%%/QXmppE2eeExtension.h
+include/QXmppQt%%QT_VER%%/QXmppE2eeMetadata.h
+include/QXmppQt%%QT_VER%%/QXmppElement.h
+include/QXmppQt%%QT_VER%%/QXmppEncryptedFileSharingProvider.h
+include/QXmppQt%%QT_VER%%/QXmppEncryptedFileSource.h
+include/QXmppQt%%QT_VER%%/QXmppEntityTimeIq.h
+include/QXmppQt%%QT_VER%%/QXmppEntityTimeManager.h
+include/QXmppQt%%QT_VER%%/QXmppError.h
+include/QXmppQt%%QT_VER%%/QXmppExtension.h
+include/QXmppQt%%QT_VER%%/QXmppFileMetadata.h
+include/QXmppQt%%QT_VER%%/QXmppFileShare.h
+include/QXmppQt%%QT_VER%%/QXmppFileSharingManager.h
+include/QXmppQt%%QT_VER%%/QXmppFileSharingProvider.h
+include/QXmppQt%%QT_VER%%/QXmppFutureUtils_p.h
+include/QXmppQt%%QT_VER%%/QXmppGeolocItem.h
+include/QXmppQt%%QT_VER%%/QXmppGlobal.h
+include/QXmppQt%%QT_VER%%/QXmppHash.h
+include/QXmppQt%%QT_VER%%/QXmppHttpFileSharingProvider.h
+include/QXmppQt%%QT_VER%%/QXmppHttpFileSource.h
+include/QXmppQt%%QT_VER%%/QXmppHttpUploadIq.h
+include/QXmppQt%%QT_VER%%/QXmppHttpUploadManager.h
+include/QXmppQt%%QT_VER%%/QXmppIbbIq.h
+include/QXmppQt%%QT_VER%%/QXmppIncomingClient.h
+include/QXmppQt%%QT_VER%%/QXmppIncomingServer.h
+include/QXmppQt%%QT_VER%%/QXmppInvokable.h
+include/QXmppQt%%QT_VER%%/QXmppIq.h
+include/QXmppQt%%QT_VER%%/QXmppIqHandling.h
+include/QXmppQt%%QT_VER%%/QXmppJingleIq.h
+include/QXmppQt%%QT_VER%%/QXmppLogger.h
+include/QXmppQt%%QT_VER%%/QXmppMamIq.h
+include/QXmppQt%%QT_VER%%/QXmppMamManager.h
+include/QXmppQt%%QT_VER%%/QXmppMessage.h
+include/QXmppQt%%QT_VER%%/QXmppMessageHandler.h
+include/QXmppQt%%QT_VER%%/QXmppMessageReaction.h
+include/QXmppQt%%QT_VER%%/QXmppMessageReceiptManager.h
+include/QXmppQt%%QT_VER%%/QXmppMixInfoItem.h
+include/QXmppQt%%QT_VER%%/QXmppMixInvitation.h
+include/QXmppQt%%QT_VER%%/QXmppMixIq.h
+include/QXmppQt%%QT_VER%%/QXmppMixParticipantItem.h
+include/QXmppQt%%QT_VER%%/QXmppMucIq.h
+include/QXmppQt%%QT_VER%%/QXmppMucManager.h
+include/QXmppQt%%QT_VER%%/QXmppNonSASLAuth.h
+include/QXmppQt%%QT_VER%%/QXmppNonza.h
+include/QXmppQt%%QT_VER%%/QXmppOutOfBandUrl.h
+include/QXmppQt%%QT_VER%%/QXmppOutgoingClient.h
+include/QXmppQt%%QT_VER%%/QXmppOutgoingServer.h
+include/QXmppQt%%QT_VER%%/QXmppPasswordChecker.h
+include/QXmppQt%%QT_VER%%/QXmppPingIq.h
+include/QXmppQt%%QT_VER%%/QXmppPresence.h
+include/QXmppQt%%QT_VER%%/QXmppPromise.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubAffiliation.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubBaseItem.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubEvent.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubEventHandler.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubIq.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubIq_p.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubItem.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubManager.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubMetadata.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubNodeConfig.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubPublishOptions.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubSubAuthorization.h
+include/QXmppQt%%QT_VER%%/QXmppPubSubSubscribeOptions.cpp
+include/QXmppQt%%QT_VER%%/QXmppPubSubSubscription.h
+include/QXmppQt%%QT_VER%%/QXmppPushEnableIq.h
+include/QXmppQt%%QT_VER%%/QXmppRegisterIq.h
+include/QXmppQt%%QT_VER%%/QXmppRegistrationManager.h
+include/QXmppQt%%QT_VER%%/QXmppRemoteMethod.h
+include/QXmppQt%%QT_VER%%/QXmppResultSet.h
+include/QXmppQt%%QT_VER%%/QXmppRosterIq.h
+include/QXmppQt%%QT_VER%%/QXmppRosterManager.h
+include/QXmppQt%%QT_VER%%/QXmppRpcIq.h
+include/QXmppQt%%QT_VER%%/QXmppRpcManager.h
+include/QXmppQt%%QT_VER%%/QXmppSendResult.h
+include/QXmppQt%%QT_VER%%/QXmppSendStanzaParams.h
+include/QXmppQt%%QT_VER%%/QXmppServer.h
+include/QXmppQt%%QT_VER%%/QXmppServerExtension.h
+include/QXmppQt%%QT_VER%%/QXmppServerPlugin.h
+include/QXmppQt%%QT_VER%%/QXmppSessionIq.h
+include/QXmppQt%%QT_VER%%/QXmppSocks.h
+include/QXmppQt%%QT_VER%%/QXmppStanza.h
+include/QXmppQt%%QT_VER%%/QXmppStartTlsPacket.h
+include/QXmppQt%%QT_VER%%/QXmppStream.h
+include/QXmppQt%%QT_VER%%/QXmppStreamFeatures.h
+include/QXmppQt%%QT_VER%%/QXmppStun.h
+include/QXmppQt%%QT_VER%%/QXmppTask.h
+include/QXmppQt%%QT_VER%%/QXmppThumbnail.h
+include/QXmppQt%%QT_VER%%/QXmppTransferManager.h
+include/QXmppQt%%QT_VER%%/QXmppTransferManager_p.h
+include/QXmppQt%%QT_VER%%/QXmppTrustLevel.h
+include/QXmppQt%%QT_VER%%/QXmppTrustManager.h
+include/QXmppQt%%QT_VER%%/QXmppTrustMemoryStorage.h
+include/QXmppQt%%QT_VER%%/QXmppTrustMessageElement.h
+include/QXmppQt%%QT_VER%%/QXmppTrustMessageKeyOwner.h
+include/QXmppQt%%QT_VER%%/QXmppTrustMessages.h
+include/QXmppQt%%QT_VER%%/QXmppTrustSecurityPolicy.h
+include/QXmppQt%%QT_VER%%/QXmppTrustStorage.h
+include/QXmppQt%%QT_VER%%/QXmppUploadRequestManager.h
+include/QXmppQt%%QT_VER%%/QXmppUserLocationManager.h
+include/QXmppQt%%QT_VER%%/QXmppUserTuneItem.h
+include/QXmppQt%%QT_VER%%/QXmppUserTuneManager.h
+include/QXmppQt%%QT_VER%%/QXmppUtils.h
+include/QXmppQt%%QT_VER%%/QXmppVCardIq.h
+include/QXmppQt%%QT_VER%%/QXmppVCardManager.h
+include/QXmppQt%%QT_VER%%/QXmppVersionIq.h
+include/QXmppQt%%QT_VER%%/QXmppVersionManager.h
+include/QXmppQt%%QT_VER%%/qxmpp_export.h
+lib/cmake/QXmpp/QXmppConfig.cmake
+lib/cmake/QXmpp/QXmppConfigVersion.cmake
+lib/cmake/QXmppOmemoQt%%QT_VER%%/QXmppOmemo-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/QXmppOmemoQt%%QT_VER%%/QXmppOmemo.cmake
+lib/cmake/QXmppOmemoQt%%QT_VER%%/QXmppOmemoQt%%QT_VER%%Config.cmake
+lib/cmake/QXmppOmemoQt%%QT_VER%%/QXmppOmemoQt%%QT_VER%%ConfigVersion.cmake
+lib/cmake/QXmppQt%%QT_VER%%/QXmpp-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/QXmppQt%%QT_VER%%/QXmpp.cmake
+lib/cmake/QXmppQt%%QT_VER%%/QXmppQt%%QT_VER%%Config.cmake
+lib/cmake/QXmppQt%%QT_VER%%/QXmppQt%%QT_VER%%ConfigVersion.cmake
+lib/libQXmppOmemoQt%%QT_VER%%.so
+lib/libQXmppOmemoQt%%QT_VER%%.so.4
+lib/libQXmppOmemoQt%%QT_VER%%.so.%%VERSION%%
+lib/libQXmppQt%%QT_VER%%.so
+lib/libQXmppQt%%QT_VER%%.so.4
+lib/libQXmppQt%%QT_VER%%.so.%%VERSION%%
+libdata/pkgconfig/QXmppQt%%QT_VER%%.pc
+%%QT5_ONLY%%libdata/pkgconfig/qxmpp.pc