aboutsummaryrefslogtreecommitdiff
path: root/net-im/scudcloud
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2018-01-20 10:25:50 +0000
committerNicola Vitale <nivit@FreeBSD.org>2018-01-20 10:25:50 +0000
commit4ec8013949ba6a66c2ff4b67d2085fbf700e60ac (patch)
tree7200e41dcf63f900b4e6a2fbf4a72acce17dc5da /net-im/scudcloud
parentac107e3859da6f1537083acbb48a0f949d73cb2b (diff)
downloadports-4ec8013949ba6a66c2ff4b67d2085fbf700e60ac.tar.gz
ports-4ec8013949ba6a66c2ff4b67d2085fbf700e60ac.zip
ScudCloud is a non official open-source desktop client app for Slack.
ScudCloud improves the Slack integration with desktop featuring: * multiple teams support * native system notifications * count of unread direct mentions at launcher/sytray icon * alert/wobbling on new messages * optional tray notifications and "Close to Tray" * follow your desktop activity and will stay online while you're logged in (if correct packages are installed) WWW: https://github.com/raelgc/scudcloud
Notes
Notes: svn path=/head/; revision=459509
Diffstat (limited to 'net-im/scudcloud')
-rw-r--r--net-im/scudcloud/Makefile39
-rw-r--r--net-im/scudcloud/distinfo3
-rw-r--r--net-im/scudcloud/files/patch-scudcloud_resources.py11
-rw-r--r--net-im/scudcloud/files/patch-setup.py11
-rw-r--r--net-im/scudcloud/files/patch-share_scudcloud.desktop8
-rw-r--r--net-im/scudcloud/pkg-descr13
6 files changed, 85 insertions, 0 deletions
diff --git a/net-im/scudcloud/Makefile b/net-im/scudcloud/Makefile
new file mode 100644
index 000000000000..bddca8365d0c
--- /dev/null
+++ b/net-im/scudcloud/Makefile
@@ -0,0 +1,39 @@
+# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= scudcloud
+PORTVERSION= 1.64
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Desktop client app for Slack
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsmin>0:devel/py-jsmin@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qt5-webkit>0:www/py-qt5-webkit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qt5-webkitwidgets>0:www/py-qt5-webkitwidgets@${PY_FLAVOR}
+
+GH_ACCOUNT= raelgc
+
+HUNSPELL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hunspell>0:textproc/py-hunspell@${PY_FLAVOR} \
+ qupzilla:www/qupzilla-qt5
+
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= HUNSPELL
+
+USES= python:3.4+
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -i.bak -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
+ ${WRKSRC}/share/${PORTNAME}.desktop \
+ ${WRKSRC}/${PORTNAME}/resources.py
+
+.include <bsd.port.mk>
diff --git a/net-im/scudcloud/distinfo b/net-im/scudcloud/distinfo
new file mode 100644
index 000000000000..27a59572cd7d
--- /dev/null
+++ b/net-im/scudcloud/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516357189
+SHA256 (raelgc-scudcloud-v1.64_GH0.tar.gz) = 669d51cb9ef619afccbf0f9cf2f1d065cc88139e2adbf9d5f355c976e2f44328
+SIZE (raelgc-scudcloud-v1.64_GH0.tar.gz) = 185675
diff --git a/net-im/scudcloud/files/patch-scudcloud_resources.py b/net-im/scudcloud/files/patch-scudcloud_resources.py
new file mode 100644
index 000000000000..b3c56cdeee6a
--- /dev/null
+++ b/net-im/scudcloud/files/patch-scudcloud_resources.py
@@ -0,0 +1,11 @@
+--- scudcloud/resources.py.orig 2018-01-19 13:48:09 UTC
++++ scudcloud/resources.py
+@@ -13,7 +13,7 @@ class Resources:
+ GOOGLE_OAUTH2_URL_RE = re.compile(r'^https://accounts.google.com/o/oauth')
+
+ SPELL_LIMIT = 6
+- SPELL_DICT_PATH = '/usr/share/hunspell'
++ SPELL_DICT_PATH = '%%LOCALBASE%%/share/hunspell'
+ DEFAULT_CONFDIR = '~/.config/scudcloud'
+ DEFAULT_CACHEDIR = '~/.cache/scudcloud'
+
diff --git a/net-im/scudcloud/files/patch-setup.py b/net-im/scudcloud/files/patch-setup.py
new file mode 100644
index 000000000000..29de3c91a1d8
--- /dev/null
+++ b/net-im/scudcloud/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-01-16 17:43:41 UTC
++++ setup.py
+@@ -38,8 +38,6 @@ def _data_files():
+ files = glob.glob(os.path.join('share', 'icons', theme, '*.svg'))
+ yield directory, files
+
+- yield os.path.join('share', 'doc', 'scudcloud'), \
+- ['LICENSE', 'README']
+ yield os.path.join('share', 'applications'), \
+ glob.glob(os.path.join('share', '*.desktop'))
+ yield os.path.join('share', 'pixmaps'), \
diff --git a/net-im/scudcloud/files/patch-share_scudcloud.desktop b/net-im/scudcloud/files/patch-share_scudcloud.desktop
new file mode 100644
index 000000000000..49ab72e84fe9
--- /dev/null
+++ b/net-im/scudcloud/files/patch-share_scudcloud.desktop
@@ -0,0 +1,8 @@
+--- share/scudcloud.desktop.orig 2018-01-19 13:45:06 UTC
++++ share/scudcloud.desktop
+@@ -9,4 +9,4 @@ Comment=ScudCloud is an open-source clie
+ Keywords=slack;chat;instant-messaging;collaboration;
+ Exec=scudcloud
+ StartupWMClass=scudcloud
+-Icon=/usr/share/pixmaps/scudcloud.png
++Icon=%%LOCALBASE%%/share/pixmaps/scudcloud.png
diff --git a/net-im/scudcloud/pkg-descr b/net-im/scudcloud/pkg-descr
new file mode 100644
index 000000000000..6a9a191b046f
--- /dev/null
+++ b/net-im/scudcloud/pkg-descr
@@ -0,0 +1,13 @@
+ScudCloud is a non official open-source desktop client app for Slack.
+
+ScudCloud improves the Slack integration with desktop featuring:
+
+ * multiple teams support
+ * native system notifications
+ * count of unread direct mentions at launcher/sytray icon
+ * alert/wobbling on new messages
+ * optional tray notifications and "Close to Tray"
+ * follow your desktop activity and will stay online while you're
+ logged in (if correct packages are installed)
+
+WWW: https://github.com/raelgc/scudcloud