aboutsummaryrefslogtreecommitdiff
path: root/net-im/ssh-chat
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-07-01 15:49:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-07-01 15:49:23 +0000
commit5d2c0aaa3c81fa13c01506d572826583cb0680a0 (patch)
treeba35fe47e8f9c05e46ee89eb4fc746402e21b4ff /net-im/ssh-chat
parentc20bb0c65beb2e8b3d0da29f495fd7a2918568d6 (diff)
downloadports-5d2c0aaa3c81fa13c01506d572826583cb0680a0.tar.gz
ports-5d2c0aaa3c81fa13c01506d572826583cb0680a0.zip
net-im/ssh-chat: Switch to USES=go:modules, fix build with go1.13beta1
PR: 238926 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=505607
Diffstat (limited to 'net-im/ssh-chat')
-rw-r--r--net-im/ssh-chat/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/net-im/ssh-chat/Makefile b/net-im/ssh-chat/Makefile
index 735ac4bf849a..dfa12aca51ea 100644
--- a/net-im/ssh-chat/Makefile
+++ b/net-im/ssh-chat/Makefile
@@ -10,28 +10,21 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= Chat over SSH
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go
+USES= go:modules
-USE_GITHUB= nodefault # the main code is in GH_TUPLE
+USE_GITHUB= yes
GH_ACCOUNT= shazow
-GH_TUPLE= shazow:ssh-chat:${DISTVERSIONFULL}:main/src/github.com/shazow/ssh-chat \
- shazow:rateio:e8e0088:rateio/src/github.com/shazow/rateio \
- alexcesaro:log:61e6862:log/src/github.com/alexcesaro/log \
- howeyc:gopass:bf9dde6:gopass/src/github.com/howeyc/gopass \
- jessevdk:go-flags:c6ca198:flags/src/github.com/jessevdk/go-flags \
- golang:crypto:c126467:crypto/src/golang.org/x/crypto \
- golang:sys:ac767d6:sys/src/golang.org/x/sys
-GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+GH_TUPLE= shazow:rateio:e8e0088:rateio/vendor/github.com/shazow/rateio \
+ alexcesaro:log:61e6862:log/vendor/github.com/alexcesaro/log \
+ howeyc:gopass:bf9dde6:gopass/vendor/github.com/howeyc/gopass \
+ jessevdk:go-flags:c6ca198:flags/vendor/github.com/jessevdk/go-flags \
+ golang:crypto:c126467:crypto/vendor/golang.org/x/crypto \
+ golang:sys:ac767d6:sys/vendor/golang.org/x/sys
-PLIST_FILES= bin/${PORTNAME}
-
-do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME} && \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
+GO_TARGET= ./cmd/${PORTNAME}
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.mk>