aboutsummaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-09-04 18:21:47 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-09-04 18:21:47 +0000
commit0220a1c455884c5ca14ad822bab400fe61d18e99 (patch)
treeff1c5cba2ae81d05656f85325b8221f10dd6d3a5 /net-im/telegram-desktop
parent5ec7129847f085a2375fdc8ad7a1ef684a06a1fc (diff)
downloadports-0220a1c455884c5ca14ad822bab400fe61d18e99.tar.gz
ports-0220a1c455884c5ca14ad822bab400fe61d18e99.zip
Remove unneeded patches forgot to remove in the last commit
While here, add USES=gl as gl.mk suggested. Reported by: Alex V. Petrov <alexvpetrov@gmail.com> Approved by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=547560
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Makefile2
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_core_update__checker.cpp22
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_cmake_lib__tgvoip.cmake20
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_effects_animation__value.h11
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_widgets_input__fields.h10
5 files changed, 1 insertions, 64 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index e762b4062256..358e1fc298fb 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -40,7 +40,7 @@ LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libxkbcommon.so:x11/libxkbcommon \
libxxhash.so:devel/xxhash
-USES= cmake compiler:c++17-lang desktop-file-utils \
+USES= cmake compiler:c++17-lang desktop-file-utils gl \
gnome pkgconfig python:3.7,build qt:5 ssl xorg
# see Bugzilla #245452 for details
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_core_update__checker.cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_core_update__checker.cpp
deleted file mode 100644
index e84100bd23ad..000000000000
--- a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_core_update__checker.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- Telegram/SourceFiles/core/update_checker.cpp.orig 2020-02-18 08:28:06 UTC
-+++ Telegram/SourceFiles/core/update_checker.cpp
-@@ -1460,6 +1460,9 @@ int UpdateChecker::size() const {
- //}
-
- bool checkReadyUpdate() {
-+#ifdef Q_OS_FREEBSD
-+ return false;
-+#endif
- QString readyFilePath = cWorkingDir() + qsl("tupdates/temp/ready"), readyPath = cWorkingDir() + qsl("tupdates/temp");
- if (!QFile(readyFilePath).exists() || cExeName().isEmpty()) {
- if (QDir(cWorkingDir() + qsl("tupdates/ready")).exists() || QDir(cWorkingDir() + qsl("tupdates/temp")).exists()) {
-@@ -1512,6 +1515,9 @@ bool checkReadyUpdate() {
- #elif defined Q_OS_UNIX // Q_OS_MAC
- QString curUpdater = (cExeDir() + qsl("Updater"));
- QFileInfo updater(cWorkingDir() + qsl("tupdates/temp/Updater"));
-+#elif defined Q_OS_FREEBSD
-+ QString curUpdater;
-+ QFileInfo updater;
- #endif // Q_OS_UNIX
- if (!updater.exists()) {
- QFileInfo current(curUpdater);
diff --git a/net-im/telegram-desktop/files/patch-Telegram_cmake_lib__tgvoip.cmake b/net-im/telegram-desktop/files/patch-Telegram_cmake_lib__tgvoip.cmake
deleted file mode 100644
index ac1f8f0fce42..000000000000
--- a/net-im/telegram-desktop/files/patch-Telegram_cmake_lib__tgvoip.cmake
+++ /dev/null
@@ -1,20 +0,0 @@
---- Telegram/cmake/lib_tgvoip.cmake.orig 2020-05-24 07:59:19 UTC
-+++ Telegram/cmake/lib_tgvoip.cmake
-@@ -793,11 +793,17 @@ else()
- )
- endif()
-
-+ find_package(PkgConfig REQUIRED)
-+ pkg_check_modules(PULSE REQUIRED IMPORTED_TARGET libpulse)
-+ pkg_check_modules(ALSA REQUIRED IMPORTED_TARGET alsa)
-+
- target_include_directories(lib_tgvoip
- PUBLIC
- ${tgvoip_loc}
- PRIVATE
- ${tgvoip_loc}/webrtc_dsp
-+ ${PULSE_INCLUDE_DIRS}
-+ ${ALSA_INCLUDE_DIRS}
- )
-
- target_link_libraries(lib_tgvoip
diff --git a/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_effects_animation__value.h b/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_effects_animation__value.h
deleted file mode 100644
index 99a37d9c177a..000000000000
--- a/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_effects_animation__value.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- Telegram/lib_ui/ui/effects/animation_value.h.orig 2020-05-29 11:22:37 UTC
-+++ Telegram/lib_ui/ui/effects/animation_value.h
-@@ -6,6 +6,8 @@
- //
- #pragma once
-
-+#include <QtGui/QPainterPath>
-+
- #include "base/basic_types.h"
-
- #include "ui/style/style_core.h"
diff --git a/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_widgets_input__fields.h b/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_widgets_input__fields.h
deleted file mode 100644
index fdaafde3ae50..000000000000
--- a/net-im/telegram-desktop/files/patch-Telegram_lib__ui_ui_widgets_input__fields.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- Telegram/lib_ui/ui/widgets/input_fields.h.orig 2020-05-29 11:22:48 UTC
-+++ Telegram/lib_ui/ui/widgets/input_fields.h
-@@ -16,6 +16,7 @@
- #include <QtWidgets/QLineEdit>
- #include <QtWidgets/QTextEdit>
- #include <QtCore/QTimer>
-+#include <QtGui/QPainterPath>
-
- class QTouchEvent;
- class Painter;