aboutsummaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-04-04 12:13:52 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-04-04 12:13:52 +0000
commit8318aaff0c007d6a179c0848f74ef8fa0f53536a (patch)
treeab7f7e3c982f821ba079de5f9fb4270a3fa255f5 /net-im/telegram-desktop
parent5ae9a25b2ddb21201390771d5ae9409b98344380 (diff)
downloadports-8318aaff0c007d6a179c0848f74ef8fa0f53536a.tar.gz
ports-8318aaff0c007d6a179c0848f74ef8fa0f53536a.zip
net-im/telegram-desktop: update to 2.0.1
Changelog: v2.0.1 Switch between folders using Ctrl+1, ..., Ctrl+8. Fix crash when a pinned in folder chat was added to archive. Fix font issues in Linux version. v2.0.0 Organize chats into Chat Folders if you have too many chats. Create custom folders with flexible settings, or use default recommendations. Pin an unlimited number of chats in each folder. Switch between folders in the new side bar to easily access all of your chats. Send :dice: to any chat to try your luck and get a random number from the animated dice. Try out the new animated emoji. While here, fix the system version string, and also add missing lz4 dependency. PR: 245227 Submitted by: henry.hu.sh@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=530649
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Makefile5
-rw-r--r--net-im/telegram-desktop/distinfo6
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp11
3 files changed, 17 insertions, 5 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index 41569b3e4be3..6e1ae44ae878 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= telegram-desktop
-DISTVERSION= 1.9.21
+DISTVERSION= 2.0.1
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@@ -29,7 +29,8 @@ LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libdbusmenu-qt5.so:devel/libdbusmenu-qt \
libhunspell-1.7.so:textproc/hunspell \
libxxhash.so:devel/xxhash \
- libenchant-2.so:textproc/enchant2
+ libenchant-2.so:textproc/enchant2 \
+ liblz4.so:archivers/liblz4
USES= cmake compiler:c++17-lang desktop-file-utils \
gnome pkgconfig python:3.7,build qt:5 ssl xorg
diff --git a/net-im/telegram-desktop/distinfo b/net-im/telegram-desktop/distinfo
index 2da5282f3bbb..3181953c8e61 100644
--- a/net-im/telegram-desktop/distinfo
+++ b/net-im/telegram-desktop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584582797
-SHA256 (tdesktop-1.9.21-full.tar.gz) = e1f9b58c1475a5044bc4d7a7ed5f89777e717ea5e6126707105e2c2d3032ffac
-SIZE (tdesktop-1.9.21-full.tar.gz) = 25848026
+TIMESTAMP = 1585708370
+SHA256 (tdesktop-2.0.1-full.tar.gz) = ced19f5bc15e26d7bf76e47841422425f664110f1aada111b9f525ab18e1723c
+SIZE (tdesktop-2.0.1-full.tar.gz) = 26106949
diff --git a/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp
new file mode 100644
index 000000000000..3bc16d78edff
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__info__linux.cpp
@@ -0,0 +1,11 @@
+--- Telegram/lib_base/base/platform/linux/base_info_linux.cpp.orig 2020-03-30 09:44:51 UTC
++++ Telegram/lib_base/base/platform/linux/base_info_linux.cpp
+@@ -65,7 +65,7 @@ QString SystemVersionPretty() {
+ const auto result = getenv("XDG_CURRENT_DESKTOP");
+ const auto value = result ? QString::fromLatin1(result) : QString();
+ const auto list = value.split(':', QString::SkipEmptyParts);
+- return list.isEmpty() ? "Linux" : "Linux " + list[0];
++ return list.isEmpty() ? "FreeBSD" : "FreeBSD " + list[0];
+ }
+
+ QString SystemCountry() {