aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-logger
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/telepathy-logger
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/telepathy-logger')
-rw-r--r--net-im/telepathy-logger/Makefile31
-rw-r--r--net-im/telepathy-logger/distinfo4
-rw-r--r--net-im/telepathy-logger/pkg-plist30
3 files changed, 33 insertions, 32 deletions
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 39a04c63c5a6..a38da11d3192 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -1,35 +1,34 @@
-# New ports collection makefile for: telepathy-logger
-# Date created: 23 July 2010
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-logger/Makefile,v 1.3 2010/09/01 23:50:23 avl Exp $
+# $MCom: ports/net-im/telepathy-logger/Makefile,v 1.14 2012/08/17 19:06:45 kwm Exp $
PORTNAME= telepathy-logger
-PORTVERSION= 0.1.7
+PORTVERSION= 0.4.0
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Logger utility library for the Telepathy framework
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib
+
+LICENSE= LGPL21
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig glib20 intltool gnomedocutils ltverhack
+USE_GNOME= gnomehack glib20 intltool gnomedocutils ltverhack libxml2 \
+ libxslt:build
+USE_PKGCONFIG= build
+USE_SQLITE= yes
USE_PYTHON_BUILD= yes
-#MAKE_JOBS_UNSAFE= yes
GLIB_SCHEMAS= org.freedesktop.Telepathy.Logger.gschema.xml
-#post-patch:
-# @${REINPLACE_CMD} -e 's|\(^pkgconfigdir =\).*|\1 ${PREFIX}/libdata/pkgconfig|' \
-# ${WRKSRC}/telepathy-glib/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g' \
+ ${WRKSRC}/tools/*.py
.include <bsd.port.mk>
diff --git a/net-im/telepathy-logger/distinfo b/net-im/telepathy-logger/distinfo
index 4e53cd3ef96f..35dcf03c5d53 100644
--- a/net-im/telepathy-logger/distinfo
+++ b/net-im/telepathy-logger/distinfo
@@ -1,2 +1,2 @@
-SHA256 (telepathy-logger-0.1.7.tar.bz2) = 5466350fee82cbd75194ffe06591a03a75904d15c6b3d4d2db9b005734dd33d1
-SIZE (telepathy-logger-0.1.7.tar.bz2) = 452362
+SHA256 (telepathy-logger-0.4.0.tar.bz2) = 06b5ab0616afd7572a1bbda58e6a9487bb305f69358c85985a8999f26f4465e5
+SIZE (telepathy-logger-0.4.0.tar.bz2) = 523642
diff --git a/net-im/telepathy-logger/pkg-plist b/net-im/telepathy-logger/pkg-plist
index 983770d4dd69..874268543d86 100644
--- a/net-im/telepathy-logger/pkg-plist
+++ b/net-im/telepathy-logger/pkg-plist
@@ -1,18 +1,23 @@
-include/telepathy-logger-0.1/telepathy-logger/entity.h
-include/telepathy-logger-0.1/telepathy-logger/entry-text.h
-include/telepathy-logger-0.1/telepathy-logger/entry.h
-include/telepathy-logger-0.1/telepathy-logger/log-manager.h
-include/telepathy-logger-0.1/telepathy-logger/telepathy-logger.h
+include/telepathy-logger-0.2/telepathy-logger/call-event.h
+include/telepathy-logger-0.2/telepathy-logger/entity.h
+include/telepathy-logger-0.2/telepathy-logger/event.h
+include/telepathy-logger-0.2/telepathy-logger/log-manager.h
+include/telepathy-logger-0.2/telepathy-logger/telepathy-logger.h
+include/telepathy-logger-0.2/telepathy-logger/text-event.h
+lib/girepository-1.0/TelepathyLogger-0.2.typelib
lib/libtelepathy-logger.a
lib/libtelepathy-logger.la
lib/libtelepathy-logger.so
-lib/libtelepathy-logger.so.1
-libdata/pkgconfig/telepathy-logger-0.1.pc
+lib/libtelepathy-logger.so.2
+libdata/pkgconfig/telepathy-logger-0.2.pc
libexec/telepathy-logger
share/dbus-1/services/org.freedesktop.Telepathy.Client.Logger.service
share/dbus-1/services/org.freedesktop.Telepathy.Logger.service
-share/gtk-doc/html/telepathy-logger/TplEntry.html
-share/gtk-doc/html/telepathy-logger/TplEntryText.html
+share/gir-1.0/TelepathyLogger-0.2.gir
+share/gtk-doc/html/telepathy-logger/TplEntity.html
+share/gtk-doc/html/telepathy-logger/TplEvent.html
+share/gtk-doc/html/telepathy-logger/TplLogManager.html
+share/gtk-doc/html/telepathy-logger/TplTextEvent.html
share/gtk-doc/html/telepathy-logger/ch-public.html
share/gtk-doc/html/telepathy-logger/home.png
share/gtk-doc/html/telepathy-logger/index.html
@@ -20,9 +25,6 @@ share/gtk-doc/html/telepathy-logger/index.sgml
share/gtk-doc/html/telepathy-logger/left.png
share/gtk-doc/html/telepathy-logger/right.png
share/gtk-doc/html/telepathy-logger/style.css
-share/gtk-doc/html/telepathy-logger/telepathy-logger-TplEntity.html
-share/gtk-doc/html/telepathy-logger/telepathy-logger-TplLogManager.html
-share/gtk-doc/html/telepathy-logger/telepathy-logger.devhelp
share/gtk-doc/html/telepathy-logger/telepathy-logger.devhelp2
share/gtk-doc/html/telepathy-logger/up.png
share/telepathy/clients/Logger.client
@@ -31,5 +33,5 @@ share/telepathy/clients/Logger.client
@dirrm share/gtk-doc/html/telepathy-logger
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
-@dirrm include/telepathy-logger-0.1/telepathy-logger
-@dirrm include/telepathy-logger-0.1
+@dirrm include/telepathy-logger-0.2/telepathy-logger
+@dirrm include/telepathy-logger-0.2