aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-qt4/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /net-im/telepathy-qt4/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'net-im/telepathy-qt4/Makefile')
-rw-r--r--net-im/telepathy-qt4/Makefile62
1 files changed, 40 insertions, 22 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index 41f67fb00b16..ff06492e5b5d 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -1,8 +1,9 @@
+# Created by: Alberto Villa <avilla@FreeBSD.org>
# $FreeBSD$
+# $MCom: ports/trunk/net-im/telepathy-qt4/Makefile 19955 2014-10-15 10:15:00Z gusi $
PORTNAME= telepathy-qt4
-PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTVERSION= 0.9.4
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME:C/4//}/
DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
@@ -12,49 +13,66 @@ COMMENT= High-level Qt binding for Telepathy
LICENSE= LGPL21
-LIB_DEPENDS= libtelepathy-farsight.so:${PORTSDIR}/net-im/telepathy-farsight \
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus
+LIB_DEPENDS= libtelepathy-farstream.so:${PORTSDIR}/net-im/telepathy-farstream \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus
USE_GNOME= libxslt:build
USE_GSTREAMER= yes
USE_QT4= corelib dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
USES= cmake pkgconfig python:build
-CMAKE_ARGS= -DENABLE_FARSIGHT:BOOL=True \
+CMAKE_ARGS= -DENABLE_FARSIGHT:BOOL=False \
+ -DENABLE_FARSTREAM:BOOL=True \
-DENABLE_TESTS:BOOL=False
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION="${PORTVERSION}"
PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
-PORTEXAMPLES= accounts cm contact-messenger extensions \
+PORTEXAMPLES= Makefile accounts cm contact-messenger extensions \
file-transfer protocols roster stream-tubes
-OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.options.mk>
-EXAMPLES_CMAKE_ON= -DENABLE_EXAMPLES:BOOL=True
-EXAMPLES_CMAKE_OFF= -DENABLE_EXAMPLES:BOOL=False
+.if ${PORT_OPTIONS:MEXAMPLES}
+CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=True
+.else
+CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=False
+.endif
pre-configure:
- @${REINPLACE_CMD} -e '/FIND_PROGRAM/ s,qmake ,,' \
+ ${REINPLACE_CMD} -e '/FIND_PROGRAM/ s/qmake //' \
${WRKSRC}/cmake/modules/FindQt.cmake
- @${REINPLACE_CMD} -e '/^add_dependencies(doxygen-doc / d' \
+ ${REINPLACE_CMD} -e '/^add_dependencies(doxygen-doc / d' \
${WRKSRC}/TelepathyQt/CMakeLists.txt
- @${REINPLACE_CMD} -e '/TelepathyQt.*\.pc/ s,pkgconfig,../libdata/pkgconfig,' \
- ${WRKSRC}/TelepathyQt/CMakeLists.txt \
- ${WRKSRC}/TelepathyQt/Farsight/CMakeLists.txt
- @${REINPLACE_CMD} -e '/$${LIBXML2_INCLUDE_DIR}/ s,$$, ${LOCALBASE}/include,' \
- ${WRKSRC}/TelepathyQt/Farsight/CMakeLists.txt
+ ${REINPLACE_CMD} -e '/TelepathyQt.*\.pc/ s|pkgconfig|../libdata/pkgconfig|' \
+ ${WRKSRC}/TelepathyQt/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|LIB_INSTALL_DIR}/pkgconfig|LIB_INSTALL_DIR}/../libdata/pkgconfig|' \
+ ${WRKSRC}/TelepathyQt/Farstream/CMakeLists.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|farstream-0.1|farstream-0.2|g' \
+ ${WRKSRC}/cmake/modules/FindFarstream.cmake
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:Nhtml:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/examples && ${RM} -rf */CMakeFiles */*.cmake */_gen */Makefile
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.for f in ${PORTEXAMPLES}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${CP} -R doc/html .
+. for f in ${PORTDOCS}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${DOCSDIR}
+. endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ cd ${WRKSRC}/examples && ${RM} -rf */CMakeFiles */*.cmake */Makefile
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+. for f in ${PORTEXAMPLES}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${EXAMPLESDIR}
-.endfor
+. endfor
+.endif
.include <bsd.port.mk>