aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-qt4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net-im/telepathy-qt4/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Notes
Diffstat (limited to 'net-im/telepathy-qt4/Makefile')
-rw-r--r--net-im/telepathy-qt4/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index 84e4a2657364..4141c0767455 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -30,11 +30,13 @@ CMAKE_ARGS= -DENABLE_EXAMPLES:BOOL=False \
-DDESIRED_QT_VERSION:STRING=${PKGNAMESUFFIX} \
-DQT_QMAKE_EXECUTABLE:FILEPATH=${QMAKE}
. if ${PKGNAMESUFFIX:M4}
-USE_QT4= corelib dbus gui network qtestlib_build xml \
+USES+= qt:4
+USE_QT= corelib dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
SHLIB_SUFFIX= 2
. else
-USE_QT5= core dbus gui network xml \
+USES+= qt:5
+USE_QT= core dbus gui network xml \
buildtools_build qmake_build testlib_build widgets_build
SHLIB_SUFFIX= 0
. endif