aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-qt5/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-07-17 16:48:19 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-07-17 16:48:19 +0000
commit714a261e2bb86c3c0aa2773f77b2436a1e190b62 (patch)
tree225304d693ec35d5caf2bbf3bdcddbc5f2b54990 /net-im/telepathy-qt5/Makefile
parentedab71186322366d803e7b0dd87ecc38e1644c52 (diff)
downloadports-714a261e2bb86c3c0aa2773f77b2436a1e190b62.tar.gz
ports-714a261e2bb86c3c0aa2773f77b2436a1e190b62.zip
Notes
Diffstat (limited to 'net-im/telepathy-qt5/Makefile')
-rw-r--r--net-im/telepathy-qt5/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-im/telepathy-qt5/Makefile b/net-im/telepathy-qt5/Makefile
new file mode 100644
index 000000000000..b2863dfd2c7f
--- /dev/null
+++ b/net-im/telepathy-qt5/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTNAME= telepathy-qt5
+PORTVERSION= 0.9.7
+CATEGORIES= net-im
+MASTER_SITES= https://telepathy.freedesktop.org/releases/${PORTNAME:C/5$//}/
+DISTNAME= ${PORTNAME:C/5$//}-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= High-level Qt binding for Telepathy
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:devel/py-dbus
+LIB_DEPENDS= libtelepathy-farstream.so:net-im/telepathy-farstream \
+ libtelepathy-glib.so:net-im/telepathy-glib
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:devel/py-dbus
+
+OPTIONS_DEFINE= DOCS
+
+USE_GNOME= glib20 libxslt:build
+USE_GSTREAMER= yes
+USE_QT5= core dbus gui network xml \
+ buildtools_build qmake_build testlib_build widgets_build
+USES= cmake:outsource gettext pathfix pkgconfig python:build
+CMAKE_ARGS= -DENABLE_EXAMPLES:BOOL=False \
+ -DENABLE_FARSIGHT:BOOL=False \
+ -DENABLE_FARSTREAM:BOOL=True \
+ -DENABLE_TESTS:BOOL=False \
+ -DDESIRED_QT_VERSION:STRING=5 \
+ -DQT_QMAKE_EXECUTABLE:FILEPATH=${QMAKE}
+USE_LDCONFIG= yes
+
+# Required because FindGObject.cmake is too old and uses the pkg-config values
+# directly (-lgobject-2.0 instead of /path/to/libgobject-2.0.so).
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+# We do not need Doxygen because the tarball already ships with prebuilt
+# documentation.
+CMAKE_ARGS+= -DDOXYGEN_EXECUTABLE:FILEPATH=""
+
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
+PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${CP} -R doc/html .
+. for f in ${PORTDOCS}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${DOCSDIR}
+. endfor
+
+.include <bsd.port.mk>