aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-qt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
commit18dd6954f3060c12b7882f4cb2a1f68dbfc0f102 (patch)
tree51edb00936e1a3da263df313cad16c1fa2858d19 /net-im/telepathy-qt
parenteb37a12fc9841da5f3a397814fbb99436d82a988 (diff)
downloadports-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.tar.gz
ports-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=213789
Diffstat (limited to 'net-im/telepathy-qt')
-rw-r--r--net-im/telepathy-qt/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/net-im/telepathy-qt/Makefile b/net-im/telepathy-qt/Makefile
index b32dd3c0e636..48759f2d6ec2 100644
--- a/net-im/telepathy-qt/Makefile
+++ b/net-im/telepathy-qt/Makefile
@@ -13,20 +13,14 @@ MASTER_SITE_SUBDIR= tapioca-voip
MAINTAINER= arved@FreeBSD.org
COMMENT= Framework for VoIP and IP applications
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
-CMAKE?= ${LOCALBASE}/bin/cmake
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DCMAKE_C_COMPILER:STRING='${CC}' \
- -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
- -DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+USE_CMAKE= yes
+CMAKE_SOURCE_PATH= ..
USE_QT_VER= 4
QT_COMPONENTS= corelib qmake uic moc rcc xml dbus
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -35,7 +29,4 @@ post-patch:
"s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
${WRKSRC}/../CMakeLists.txt
-do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
-
.include <bsd.port.mk>