aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-salut
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/telepathy-salut
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/telepathy-salut')
-rw-r--r--net-im/telepathy-salut/Makefile28
-rw-r--r--net-im/telepathy-salut/distinfo4
-rw-r--r--net-im/telepathy-salut/files/patch-lib_gibber_gibber-xmpp-connection-listener.c10
-rw-r--r--net-im/telepathy-salut/files/patch-src_salut-contact.h11
-rw-r--r--net-im/telepathy-salut/files/patch-src_salut-self.c10
-rw-r--r--net-im/telepathy-salut/pkg-plist13
6 files changed, 24 insertions, 52 deletions
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 16a4a6c12d11..3e6e39709bb3 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -1,36 +1,28 @@
-# New ports collection makefile for: telepathy-salut
-# Date created: Apr 16 2007
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-salut/Makefile,v 1.4 2009/01/08 07:12:15 marcus Exp $
-#
+# $MCom: ports/net-im/telepathy-salut/Makefile,v 1.9 2012/08/17 19:06:46 kwm Exp $
PORTNAME= telepathy-salut
-PORTVERSION= 0.4.0
+PORTVERSION= 0.8.0
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Link-local Connection Manager for Telepathy Framework
-LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
- avahi-glib.pc:${PORTSDIR}/net/avahi-app \
- telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
- libsoup-2.4.pc:${PORTSDIR}/devel/libsoup
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+LIB_DEPENDS= avahi-glib.1:${PORTSDIR}/net/avahi-app \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack glib20 libxslt:build
+USE_PKGCONFIG= build
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+USE_SQLITE= 3
+CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no
CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
MAN8= telepathy-salut.8
diff --git a/net-im/telepathy-salut/distinfo b/net-im/telepathy-salut/distinfo
index 85e54116a36b..555f29083631 100644
--- a/net-im/telepathy-salut/distinfo
+++ b/net-im/telepathy-salut/distinfo
@@ -1,2 +1,2 @@
-SHA256 (telepathy-salut-0.4.0.tar.gz) = f87dfe3d1b54243ac4f8eff5ca6aa8b39e9a06be5ad6be79e68599bd324bc9c8
-SIZE (telepathy-salut-0.4.0.tar.gz) = 1174079
+SHA256 (telepathy-salut-0.8.0.tar.gz) = f504faf472e81c17c2707696124d4219fe869c83d7cdbbe53a035eb724bfb5ce
+SIZE (telepathy-salut-0.8.0.tar.gz) = 1822511
diff --git a/net-im/telepathy-salut/files/patch-lib_gibber_gibber-xmpp-connection-listener.c b/net-im/telepathy-salut/files/patch-lib_gibber_gibber-xmpp-connection-listener.c
deleted file mode 100644
index 842337118809..000000000000
--- a/net-im/telepathy-salut/files/patch-lib_gibber_gibber-xmpp-connection-listener.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/gibber/gibber-xmpp-connection-listener.c.orig 2010-05-20 06:10:39.000000000 -0400
-+++ lib/gibber/gibber-xmpp-connection-listener.c 2010-07-24 20:48:34.000000000 -0400
-@@ -23,6 +23,7 @@
- #include <string.h>
- #include <time.h>
- #include <sys/types.h>
-+#include <netinet/in.h>
- #include <unistd.h>
- #include <errno.h>
-
diff --git a/net-im/telepathy-salut/files/patch-src_salut-contact.h b/net-im/telepathy-salut/files/patch-src_salut-contact.h
deleted file mode 100644
index b27d1b466ebc..000000000000
--- a/net-im/telepathy-salut/files/patch-src_salut-contact.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/salut-contact.h.orig Thu Apr 19 17:06:44 2007
-+++ src/salut-contact.h Thu Apr 19 17:08:20 2007
-@@ -20,6 +20,8 @@
- #ifndef __SALUT_CONTACT_H__
- #define __SALUT_CONTACT_H__
-
-+#include <sys/socket.h>
-+
- #include <netinet/in.h>
- #include <glib-object.h>
-
diff --git a/net-im/telepathy-salut/files/patch-src_salut-self.c b/net-im/telepathy-salut/files/patch-src_salut-self.c
deleted file mode 100644
index 27bb5b5a7163..000000000000
--- a/net-im/telepathy-salut/files/patch-src_salut-self.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/salut-self.c.orig Thu Apr 19 17:09:13 2007
-+++ src/salut-self.c Thu Apr 19 17:10:24 2007
-@@ -24,6 +24,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
- #include <netdb.h>
- #include <errno.h>
-
diff --git a/net-im/telepathy-salut/pkg-plist b/net-im/telepathy-salut/pkg-plist
index fba720fb7c8c..9e7944e82d2e 100644
--- a/net-im/telepathy-salut/pkg-plist
+++ b/net-im/telepathy-salut/pkg-plist
@@ -1,7 +1,18 @@
+lib/telepathy/salut-0/lib/libsalut-plugins-0.8.0.so
+lib/telepathy/salut-0/lib/libsalut-plugins.la
+lib/telepathy/salut-0/lib/libsalut-plugins.so
+lib/telepathy/salut-0/lib/libwocky-telepathy-salut-0.8.0.so
+lib/telepathy/salut-0/lib/libwocky.a
+lib/telepathy/salut-0/lib/libwocky.la
+lib/telepathy/salut-0/lib/libwocky.so
libexec/telepathy-salut
-share/telepathy/managers/salut.manager
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.salut.service
%%DOCSDIR%%/clique.html
+share/telepathy/managers/salut.manager
@dirrmtry share/telepathy/managers
@dirrmtry share/telepathy
@dirrm %%DOCSDIR%%
+@dirrmtry lib/telepathy/salut-0/plugins
+@dirrmtry lib/telepathy/salut-0/lib
+@dirrmtry lib/telepathy/salut-0
+@dirrmtry lib/telepathy