aboutsummaryrefslogtreecommitdiff
path: root/net-im/ttytter/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-11-04 05:26:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-11-04 05:26:38 +0000
commit1f796da09358138e99d9bd7aab9dec457bbc473b (patch)
tree2ba65ca101d6360884db91234b701d073f08962e /net-im/ttytter/Makefile
parentc923ea00b2aaa2a52583f3682a0ff030d9d8ac0b (diff)
downloadports-1f796da09358138e99d9bd7aab9dec457bbc473b.tar.gz
ports-1f796da09358138e99d9bd7aab9dec457bbc473b.zip
Notes
Diffstat (limited to 'net-im/ttytter/Makefile')
-rw-r--r--net-im/ttytter/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
index e2fc083d6ba1..6e56017f6394 100644
--- a/net-im/ttytter/Makefile
+++ b/net-im/ttytter/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
PORTNAME= ttytter
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.6
CATEGORIES= net-im
MASTER_SITES= http://www.floodgap.com/software/ttytter/dist1/
-DISTFILES= 1.1.05.txt
+DISTFILES= 1.1.06.txt
EXTRACT_ONLY=
MAINTAINER= jdunn@aquezada.com
@@ -20,7 +20,8 @@ RUN_DEPENDS= ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
NO_BUILD= yes
USE_PERL5_RUN= yes
-OPTIONS= READLINE "Include rich readline support" on
+OPTIONS= READLINE "Include rich readline support" on \
+ RLTTYTTER "Use T::R::TTYtter readline driver (beta!)" off \
PLIST_FILES= bin/${PORTNAME}
@@ -30,6 +31,10 @@ PLIST_FILES= bin/${PORTNAME}
RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
.endif
+.if defined(WITH_RLTTYTTER)
+RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/TTYtter.pm:${PORTSDIR}/devel/p5-ReadLine-TTYtter
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.txt