aboutsummaryrefslogtreecommitdiff
path: root/net-im/uTox
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-02-07 18:39:11 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-02-07 18:39:11 +0000
commit6c15557e9cf9c14214b177833967088f44384de5 (patch)
tree4c72fe0ef3219d093bc2bd6b315446171a9d66e8 /net-im/uTox
parent42a370934d8f5397d1b1ab3130312d2886572018 (diff)
downloadports-6c15557e9cf9c14214b177833967088f44384de5.tar.gz
ports-6c15557e9cf9c14214b177833967088f44384de5.zip
unbreak net-im/uTox on 10.3-RELEASE amd64
[ 83%] Building C object CMakeFiles/utox.dir/src/main.c.o /usr/bin/cc -I/usr/local/include/freetype2 -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -Wall -Wextra -fno-strict-aliasing -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -std=gnu99 -o CMakeFiles/utox.dir/src/main.c.o -c /wrkdirs/usr/ports/net-im/uTox/work/uTox-1835eae/src/main.c In file included from /wrkdirs/usr/ports/net-im/uTox/work/uTox-1835eae/src/main.c:5: In file included from /wrkdirs/usr/ports/net-im/uTox/work/uTox-1835eae/src/main.h:282: In file included from /wrkdirs/usr/ports/net-im/uTox/work/uTox-1835eae/src/stb_image.h:678: /usr/include/clang/3.4.1/emmintrin.h:1444:21: error: expected '(' after 'asm' __asm__ volatile ("pause"); ^ /wrkdirs/usr/ports/net-im/uTox/work/uTox-1835eae/src/main.h:84:21: note: expanded from macro 'volatile' #define volatile(x) x ^ PR: 216332 Submitted by: cpm, amdmi3 Reviewed by: matthew Approved by: matthew (mentor), portmaster@BSDforge.com (maintainer timeout, 2 weeks) Differential Revision: https://reviews.freebsd.org/D9477
Notes
Notes: svn path=/head/; revision=433579
Diffstat (limited to 'net-im/uTox')
-rw-r--r--net-im/uTox/Makefile2
-rw-r--r--net-im/uTox/files/patch-src_main.h2
-rw-r--r--net-im/uTox/pkg-plist1
3 files changed, 4 insertions, 1 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 254d1742abdf..6c1fc01b71f5 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -2,6 +2,7 @@
PORTNAME= uTox
PORTVERSION= 0.11.1
+PORTREVISION= 1
CATEGORIES= net-im net-p2p
MAINTAINER= portmaster@BSDforge.com
@@ -41,5 +42,6 @@ pre-configure:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox
+ ${INSTALL_DATA} ${WRKSRC}/icons/utox-128x128.png ${STAGEDIR}${PREFIX}/share/pixmaps/utox.png
.include <bsd.port.mk>
diff --git a/net-im/uTox/files/patch-src_main.h b/net-im/uTox/files/patch-src_main.h
index 02d0d9fdccc7..85ba916bbb35 100644
--- a/net-im/uTox/files/patch-src_main.h
+++ b/net-im/uTox/files/patch-src_main.h
@@ -7,7 +7,7 @@
-#ifndef __OBJC__
-#define volatile(x)(x)
+#if !defined(__OBJC__) || defined(__NetBSD__) || defined(__FreeBSD__)
-+#define volatile(x) x
++#define volatile(x)(x)
#endif
#define SCALE(x) (((int)((ui_scale / 10.0) * ((double)x))) ?: 1)
diff --git a/net-im/uTox/pkg-plist b/net-im/uTox/pkg-plist
index c482abad2ca1..1510ed4baff9 100644
--- a/net-im/uTox/pkg-plist
+++ b/net-im/uTox/pkg-plist
@@ -1,3 +1,4 @@
bin/utox
share/applications/utox.desktop
+share/pixmaps/utox.png
man/man1/utox.1.gz