aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-06-29 01:14:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-06-29 01:17:10 +0000
commit01e46eed8d2d9a00a9bce6216f03a49f184d6e6e (patch)
treefa41d9e7988efbd9319b4bcc7b6801ae4df9c512 /net-im
parent3103c302f541276ffc05e4aee6ec3d867e4c0e08 (diff)
downloadports-01e46eed8d2d9a00a9bce6216f03a49f184d6e6e.tar.gz
ports-01e46eed8d2d9a00a9bce6216f03a49f184d6e6e.zip
net-im/toxext: New port: Extension library for tox
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/toxext/Makefile24
-rw-r--r--net-im/toxext/distinfo3
-rw-r--r--net-im/toxext/pkg-descr10
-rw-r--r--net-im/toxext/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index fc5601fd1bb4..5b868c71941e 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -171,6 +171,7 @@
SUBDIR += toot
SUBDIR += tox
SUBDIR += toxbot
+ SUBDIR += toxext
SUBDIR += toxic
SUBDIR += toxins
SUBDIR += tut
diff --git a/net-im/toxext/Makefile b/net-im/toxext/Makefile
new file mode 100644
index 000000000000..071218b7e7b4
--- /dev/null
+++ b/net-im/toxext/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= toxext
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.2
+CATEGORIES= net-im net-p2p
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extension library for tox
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libopus.so:audio/opus \
+ libsodium.so:security/libsodium \
+ libtoxcore.so:net-im/tox \
+ libvpx.so:multimedia/libvpx
+
+USES= cmake localbase:ldflags pkgconfig
+USE_GITHUB= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+CFLAGS+= -fPIC # see https://github.com/toxext/toxext/issues/7
+
+.include <bsd.port.mk>
diff --git a/net-im/toxext/distinfo b/net-im/toxext/distinfo
new file mode 100644
index 000000000000..3e1f3294627a
--- /dev/null
+++ b/net-im/toxext/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624921343
+SHA256 (toxext-toxext-v0.0.2_GH0.tar.gz) = 047093eeed396ea9b4a3f0cd0a6bc4e0e09b339e2b03ba4b676e30888fe6acde
+SIZE (toxext-toxext-v0.0.2_GH0.tar.gz) = 34178
diff --git a/net-im/toxext/pkg-descr b/net-im/toxext/pkg-descr
new file mode 100644
index 000000000000..06c009f5734a
--- /dev/null
+++ b/net-im/toxext/pkg-descr
@@ -0,0 +1,10 @@
+Tox provides a reasonable base set of features, but new features are slow to
+implement, and may not be wanted by all clients. This is reasonable as any
+protocol changes are API breaking and force clients to update to use them. Once
+the features are in they are there forever meaning quality of the API and the
+network layer have to be very strong.
+
+An extension library with negotiation allows more experimentation with less risk
+resulting in more features for tox clients.
+
+WWW: https://github.com/toxext/toxext
diff --git a/net-im/toxext/pkg-plist b/net-im/toxext/pkg-plist
new file mode 100644
index 000000000000..ac62b07b8aa7
--- /dev/null
+++ b/net-im/toxext/pkg-plist
@@ -0,0 +1,8 @@
+include/toxext/mock_fixtures.h
+include/toxext/mock_tox.h
+include/toxext/toxext.h
+include/toxext/toxext_util.h
+lib/cmake/ToxExt/ToxExtConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ToxExt/ToxExtConfig.cmake
+lib/libtoxext.so
+lib/libtoxext_mock.so