aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-03-27 14:10:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-03-27 14:10:06 +0000
commit13fbe8f636e31b57fd7bb632d75d7a1720a146c9 (patch)
tree0d9186de1f38caa297bf82b04de7a9dfe89f6a15 /net-im
parent7cd23d38ac77777ceac8d2e288b0421209617e8a (diff)
downloadports-13fbe8f636e31b57fd7bb632d75d7a1720a146c9.tar.gz
ports-13fbe8f636e31b57fd7bb632d75d7a1720a146c9.zip
net-im/libsignal-client: Do not depend on rust-nightly
Add RUSTC_BOOTSTRAP=1 to enable required nightly features to build with stable Rust. With hat: rust
Notes
Notes: svn path=/head/; revision=569333
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libsignal-client/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-im/libsignal-client/Makefile b/net-im/libsignal-client/Makefile
index dcc42360b239..0ed641dd651e 100644
--- a/net-im/libsignal-client/Makefile
+++ b/net-im/libsignal-client/Makefile
@@ -11,10 +11,7 @@ COMMENT= Implementation of the Signal client protocol
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-# Rust stable is not supported currently:
-# https://github.com/signalapp/libsignal-client/issues/141
-BUILD_DEPENDS= rust-nightly>=0:lang/rust-nightly \
- protoc:devel/protobuf
+BUILD_DEPENDS= protoc:devel/protobuf
USES= cargo
USE_GITHUB= yes
@@ -210,11 +207,12 @@ CARGO_CRATES= addr2line-0.13.0 \
x25519-dalek-1.1.0 \
zeroize-1.1.1 \
zeroize_derive-1.0.1
-# CARGO_BUILDDEP=no is needed to force the use of rust-nightly.
-CARGO_BUILDDEP= no
CARGO_BUILD_ARGS= --package libsignal-jni
-CARGO_ENV= CARGO_PROFILE_RELEASE_LTO=thin
CARGO_INSTALL= no
+# requires nightly features to build:
+# https://github.com/signalapp/libsignal-client/issues/141
+MAKE_ENV= CARGO_PROFILE_RELEASE_LTO=thin \
+ RUSTC_BOOTSTRAP=1
USE_LDCONFIG= yes
PLIST_FILES= lib/libsignal_jni.so