aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 01:33:49 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 01:33:49 +0000
commit14ee3e690201e61acd210e6ba737850d1af43ec4 (patch)
tree18cdee7e8da28ce10a24ef3071156a35ea452ddc /net-im
parent537bff8a3e7b6df99d7c7dc262fab3bef2d18d4c (diff)
downloadports-14ee3e690201e61acd210e6ba737850d1af43ec4.tar.gz
ports-14ee3e690201e61acd210e6ba737850d1af43ec4.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ayttm/Makefile69
-rw-r--r--net-im/ayttm/distinfo6
-rw-r--r--net-im/ayttm/pkg-plist22
3 files changed, 49 insertions, 48 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index 49c9f6ba49ec..ec85bf3811bf 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ayttm
-PORTVERSION= 0.4.6.17
-PORTREVISION= 6
+PORTVERSION= 0.5.0.45
CATEGORIES= net-im
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -17,68 +16,48 @@ COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
- gpgme03.9:${PORTSDIR}/security/gpgme03 \
+ gpgme.17:${PORTSDIR}/security/gpgme \
pspell.16:${PORTSDIR}/textproc/aspell
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+OPTIONS= ARTS "Enable aRts support" off \
+ ESOUND "Enable EsounD support" off
-USE_XORG= xpm
USE_BZIP2= yes
-USE_GCC= 3.4
-WANT_GNOME= yes
-USE_GNOME= gdkpixbuf gnometarget
+USE_XORG= xpm xscrnsaver
+USE_GNOME= gnometarget gtk20
USE_OPENSSL= yes
-USE_AUTOTOOLS= libltdl:15 libtool:15
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libltdl:15 libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-smtp --enable-jasper-filter
+CONFIGURE_ARGS= --enable-oscar --disable-workwizu --enable-smtp --enable-lj
MAN1= ayttm.1
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mesound}!=""
-USE_GNOME+= esound
-PKGNAMESUFFIX= -esound
-PLIST_SUB+= ESOUND=""
-.else
-CONFIGURE_ARGS+= --disable-esd
-PLIST_SUB+= ESOUND="@comment "
-.endif
-
-.if defined(WITH_LIBARTS)
-LIB_DEPENDS+= artsc:${PORTSDIR}/audio/libarts
-PLIST_SUB+= LIBARTS=""
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
.else
CONFIGURE_ARGS+= --disable-arts
-PLIST_SUB+= LIBARTS="@comment "
.endif
-.if !defined(WITHOUT_XFT)
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
-CONFIGURE_ARGS+= --enable-xft
-CPPFLAGS+= `freetype-config --cflags`
-LDFLAGS+= `freetype-config --libs`
+.if defined(WITH_ESOUND)
+USE_GNOME+= esound
+.else
+CONFIGURE_ARGS+= --disable-esd
.endif
-pre-everything::
- @${ECHO_MSG} "Ayttm has the following tunable option(s):"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_GNOME=esound Truns off EsounD support"
- @${ECHO_MSG} " WITH_LIBARTS=yes Turns on libArts support"
- @${ECHO_MSG} " WITHOUT_XFT=yes Turns off Xft support"
- @${ECHO_MSG} ""
-
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g; \
- s|gpgme-config|gpgme03-config|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|= pixmaps|=|g ; \
- s|^Utilities|#Utilities|g ; \
- s|^gnome|#gnome|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-L/usr/local/lib||g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ /CFLAGS=/s|-pthread|${PTHREAD_CFLAGS}|g ; \
+ /LIBS=/s|-L/usr/X11R6/lib||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|/gnome/apps/Internet|/applications|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-L/usr/local/lib/pth/||g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.post.mk>
diff --git a/net-im/ayttm/distinfo b/net-im/ayttm/distinfo
index 541a134846b6..8fd5a3a4119f 100644
--- a/net-im/ayttm/distinfo
+++ b/net-im/ayttm/distinfo
@@ -1,3 +1,3 @@
-MD5 (ayttm-0.4.6-17.tar.bz2) = 50c62c447f85ac51db46df7a5ae77d6b
-SHA256 (ayttm-0.4.6-17.tar.bz2) = 071aed07491a786fe747be069756dcf392b17e129bcdd863af989c566d94db69
-SIZE (ayttm-0.4.6-17.tar.bz2) = 1365168
+MD5 (ayttm-0.5.0-45.tar.bz2) = b609a148cd36ecb219c2b3f1513bfbd0
+SHA256 (ayttm-0.5.0-45.tar.bz2) = 4c732c742205f04023b09c2a884ace558ec2bd58ddcf3e9db1bd56395cbc48b9
+SIZE (ayttm-0.5.0-45.tar.bz2) = 1408451
diff --git a/net-im/ayttm/pkg-plist b/net-im/ayttm/pkg-plist
index a565cbfc2447..7256a896b90b 100644
--- a/net-im/ayttm/pkg-plist
+++ b/net-im/ayttm/pkg-plist
@@ -1,6 +1,15 @@
bin/ayttm
bin/ayttm_streamer_wrapper.sh
etc/ayttmrc
+include/ayttm/yahoo2.h
+include/ayttm/yahoo2_callbacks.h
+include/ayttm/yahoo2_types.h
+include/ayttm/yahoo_fn.h
+include/ayttm/yahoo_httplib.h
+include/ayttm/yahoo_list.h
+lib/ayttm/aim-oscar.a
+lib/ayttm/aim-oscar.la
+lib/ayttm/aim-oscar.so
lib/ayttm/aim-toc.a
lib/ayttm/aim-toc.la
lib/ayttm/aim-toc.so
@@ -10,6 +19,9 @@ lib/ayttm/autotrans.so
lib/ayttm/aycryption.a
lib/ayttm/aycryption.la
lib/ayttm/aycryption.so
+lib/ayttm/custmsg.a
+lib/ayttm/custmsg.la
+lib/ayttm/custmsg.so
lib/ayttm/icq-toc.a
lib/ayttm/icq-toc.la
lib/ayttm/icq-toc.so
@@ -37,6 +49,9 @@ lib/ayttm/irc.so
lib/ayttm/jabber.a
lib/ayttm/jabber.la
lib/ayttm/jabber.so
+lib/ayttm/lj.a
+lib/ayttm/lj.la
+lib/ayttm/lj.so
lib/ayttm/middle.a
lib/ayttm/middle.la
lib/ayttm/middle.so
@@ -61,6 +76,8 @@ lib/ayttm/video_capture.so
lib/ayttm/yahoo2.a
lib/ayttm/yahoo2.la
lib/ayttm/yahoo2.so
+share/applications/ayttm.desktop
+share/applnk/Internet/ayttm.desktop
%%DATADIR%%/smileys/Console Smileys/aysmile.rc
%%DATADIR%%/smileys/Console Smileys/blank.xpm
%%DATADIR%%/smileys/Console Smileys/blush.xpm
@@ -95,9 +112,14 @@ lib/ayttm/yahoo2.so
%%DATADIR%%/sounds/BuddyLeave.au
%%DATADIR%%/sounds/Receive.au
%%DATADIR%%/sounds/Send.au
+share/pixmaps/ayttm.png
+@dirrmtry share/applnk/Internet
+@dirrmtry share/applnk
+@dirrmtry share/applications
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/smileys/Giles Smileys
@dirrm %%DATADIR%%/smileys/Console Smileys
@dirrm %%DATADIR%%/smileys
@dirrm %%DATADIR%%
@dirrm lib/ayttm
+@dirrm include/ayttm