aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-07-06 15:18:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-07-06 15:18:01 +0000
commit2b11990f8efab7fad2e491a31647ab25889df4a0 (patch)
treed8fdf2bb409f7920f3c05ca6a6b15ed94fb48640 /net-im
parent8760300d5b358c07f72a2e6afb6ab4022a5f3016 (diff)
downloadports-2b11990f8efab7fad2e491a31647ab25889df4a0.tar.gz
ports-2b11990f8efab7fad2e491a31647ab25889df4a0.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile2
-rw-r--r--net-im/libsignon-glib/Makefile38
-rw-r--r--net-im/libsignon-glib/distinfo3
-rw-r--r--net-im/libsignon-glib/pkg-descr7
-rw-r--r--net-im/libsignon-glib/pkg-plist47
-rw-r--r--net-im/telepathy-accounts-signon/Makefile33
-rw-r--r--net-im/telepathy-accounts-signon/distinfo3
-rw-r--r--net-im/telepathy-accounts-signon/pkg-descr5
8 files changed, 138 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 25a608eb652c..5b76f006ba64 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -63,6 +63,7 @@
SUBDIR += libnice-gst1
SUBDIR += libpurple
SUBDIR += libqtelegram-ae
+ SUBDIR += libsignon-glib
SUBDIR += libstrophe
SUBDIR += libtelepathy
SUBDIR += libyahoo2
@@ -169,6 +170,7 @@
SUBDIR += telegram
SUBDIR += telegram-purple
SUBDIR += telegramqml
+ SUBDIR += telepathy-accounts-signon
SUBDIR += telepathy-butterfly
SUBDIR += telepathy-farsight
SUBDIR += telepathy-farstream
diff --git a/net-im/libsignon-glib/Makefile b/net-im/libsignon-glib/Makefile
new file mode 100644
index 000000000000..ac60d1162d0a
--- /dev/null
+++ b/net-im/libsignon-glib/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= ${GL_PROJECT}
+PORTVERSION= 1.14
+CATEGORIES= net-im
+MASTER_SITES= https://gitlab.com/${GL_ACCOUNT}/${GL_PROJECT}/repository/archive${EXTRACT_SUFX}?ref=${GL_TAGNAME}&num;/ \
+ LOCAL/tcberner/${GL_ACCOUNT}/
+DIST_SUBDIR= KDE/${GL_ACCOUNT}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= GLib-based client library for applications handling account authentication
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= gtkdocize:textproc/gtk-doc \
+ signond:sysutils/signon-qt5
+RUN_DEPENDS= signond:sysutils/signon-qt5
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --disable-tests --enable-gtk-doc
+
+USES= autoreconf gmake libtool pathfix pkgconfig python tar:bz2
+USE_GNOME= introspection pygobject3
+
+PATHFIX_MAKEFILEIN= Makefile.am
+
+# gitlab variables
+GL_ACCOUNT= accounts-sso
+GL_PROJECT= libsignon-glib
+GL_TAGNAME= 4e85baaf483268d04bbf835bebeac4ae30c7c327
+WRKSRC= ${WRKDIR}/${GL_PROJECT}-${GL_TAGNAME}-${GL_TAGNAME}
+
+# Run gtdocize as done in autogen.sh
+pre-configure:
+ cd ${CONFIGURE_WRKSRC} && gtkdocize --copy --flavour no-tmpl
+
+.include <bsd.port.mk>
diff --git a/net-im/libsignon-glib/distinfo b/net-im/libsignon-glib/distinfo
new file mode 100644
index 000000000000..ad5d961d1bd7
--- /dev/null
+++ b/net-im/libsignon-glib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470555249
+SHA256 (KDE/accounts-sso/libsignon-glib-1.14.tar.bz2) = ec49dd2680ff07211e51745eccfc2b5e14452480e1d340eb76b93d54a0c2cede
+SIZE (KDE/accounts-sso/libsignon-glib-1.14.tar.bz2) = 44488
diff --git a/net-im/libsignon-glib/pkg-descr b/net-im/libsignon-glib/pkg-descr
new file mode 100644
index 000000000000..1a79f3303fc6
--- /dev/null
+++ b/net-im/libsignon-glib/pkg-descr
@@ -0,0 +1,7 @@
+Single signon authentication library for GLib applications
+
+This project is a library for managing single signon credentials which can be
+used from GLib applications. It is effectively a GLib binding for the D-Bus
+API provided by signond. It is part of the accounts-sso project:
+
+WWW: https://gitlab.com/accounts-sso/libsignon-glib
diff --git a/net-im/libsignon-glib/pkg-plist b/net-im/libsignon-glib/pkg-plist
new file mode 100644
index 000000000000..2717eee0a0b0
--- /dev/null
+++ b/net-im/libsignon-glib/pkg-plist
@@ -0,0 +1,47 @@
+include/libsignon-glib/signon-auth-service.h
+include/libsignon-glib/signon-auth-session.h
+include/libsignon-glib/signon-enum-types.h
+include/libsignon-glib/signon-errors.h
+include/libsignon-glib/signon-glib.h
+include/libsignon-glib/signon-identity-info.h
+include/libsignon-glib/signon-identity.h
+include/libsignon-glib/signon-types.h
+lib/girepository-1.0/Signon-1.0.typelib
+lib/libsignon-glib.so
+lib/libsignon-glib.so.1
+lib/libsignon-glib.so.1.0.0
+%%PYTHON_SITELIBDIR%%/gi/overrides/Signon.py
+%%PYTHON_SITELIBDIR%%/gi/overrides/Signon.pyc
+%%PYTHON_SITELIBDIR%%/gi/overrides/Signon.%%PYTHON_PYOEXTENSION%%
+libdata/pkgconfig/libsignon-glib.pc
+share/gir-1.0/Signon-1.0.gir
+share/gtk-doc/html/libsignon-glib/SignonAuthService.html
+share/gtk-doc/html/libsignon-glib/SignonAuthSession.html
+share/gtk-doc/html/libsignon-glib/SignonIdentity.html
+share/gtk-doc/html/libsignon-glib/SignonIdentityInfo.html
+share/gtk-doc/html/libsignon-glib/annotation-glossary.html
+share/gtk-doc/html/libsignon-glib/api-index-1-8.html
+share/gtk-doc/html/libsignon-glib/api-index-deprecated.html
+share/gtk-doc/html/libsignon-glib/api-index-full.html
+share/gtk-doc/html/libsignon-glib/appendices.html
+share/gtk-doc/html/libsignon-glib/credential-management.html
+share/gtk-doc/html/libsignon-glib/gdbus-com.google.code.AccountsSSO.SingleSignOn.AuthService.html
+share/gtk-doc/html/libsignon-glib/gdbus-com.google.code.AccountsSSO.SingleSignOn.AuthSession.html
+share/gtk-doc/html/libsignon-glib/gdbus-com.google.code.AccountsSSO.SingleSignOn.Identity.html
+share/gtk-doc/html/libsignon-glib/home.png
+share/gtk-doc/html/libsignon-glib/index.html
+share/gtk-doc/html/libsignon-glib/left-insensitive.png
+share/gtk-doc/html/libsignon-glib/left.png
+share/gtk-doc/html/libsignon-glib/libsignon-glib-SignonError.html
+share/gtk-doc/html/libsignon-glib/libsignon-glib-objects.html
+share/gtk-doc/html/libsignon-glib/libsignon-glib-overview.html
+share/gtk-doc/html/libsignon-glib/libsignon-glib.devhelp2
+share/gtk-doc/html/libsignon-glib/object-tree.html
+share/gtk-doc/html/libsignon-glib/right-insensitive.png
+share/gtk-doc/html/libsignon-glib/right.png
+share/gtk-doc/html/libsignon-glib/signond-dbus-api.html
+share/gtk-doc/html/libsignon-glib/style.css
+share/gtk-doc/html/libsignon-glib/up-insensitive.png
+share/gtk-doc/html/libsignon-glib/up.png
+share/vala/vapi/signon.vapi
+@comment share/gtk-doc/html/libsignon-glib/index.sgml
diff --git a/net-im/telepathy-accounts-signon/Makefile b/net-im/telepathy-accounts-signon/Makefile
new file mode 100644
index 000000000000..62e724811699
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= ${GL_PROJECT}
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= https://gitlab.com/${GL_ACCOUNT}/${GL_PROJECT}/repository/archive${EXTRACT_SUFX}?ref=${GL_TAGNAME}&num;/ \
+ LOCAL/tcberner/${GL_ACCOUNT}/
+DIST_SUBDIR= KDE/${GL_ACCOUNT}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Telepathy libaccounts and libsignon plugin
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
+
+LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
+ libmission-control-plugins.so:net-im/telepathy-mission-control \
+ libsignon-glib.so:net-im/libsignon-glib
+
+USES= gettext pkgconfig qmake tar:bz2
+USE_QT5= buildtools_build core qmake_build
+
+USE_LDCONFIG= YES
+
+# gitlab variables
+GL_ACCOUNT= accounts-sso
+GL_PROJECT= telepathy-accounts-signon
+GL_TAGNAME= f01a6d9eccad24a3cb4a5300fb0ae0fd426cc815
+WRKSRC= ${WRKDIR}/${GL_PROJECT}-${GL_TAGNAME}-${GL_TAGNAME}
+
+PLIST_FILES= lib/mission-control-plugins.0/mcp-account-manager-accounts-sso.so
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-accounts-signon/distinfo b/net-im/telepathy-accounts-signon/distinfo
new file mode 100644
index 000000000000..a3316c72eb28
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470554779
+SHA256 (KDE/accounts-sso/telepathy-accounts-signon-1.0.tar.bz2) = 42d16d0f96bb9d60b3d7e9f42cc505fc6bc4e02fee0fcb3e9afd159e4e7197cf
+SIZE (KDE/accounts-sso/telepathy-accounts-signon-1.0.tar.bz2) = 15528
diff --git a/net-im/telepathy-accounts-signon/pkg-descr b/net-im/telepathy-accounts-signon/pkg-descr
new file mode 100644
index 000000000000..8c0e2c61f76d
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/pkg-descr
@@ -0,0 +1,5 @@
+A mission control plugin for Telepathy, integrating with libaccounts and libsignon
+to provide IM accounts and authentication. This code is based on Nemo Mobile's
+fork of the plugin from Empathy's ubuntu-online-account support.
+
+WWW: https://gitlab.com/accounts-sso/telepathy-accounts-signon