aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-17 11:03:15 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-17 11:03:15 +0000
commit62cdf18706b72387c5fb724c936e10440cdae823 (patch)
tree9d419fa28632f9c3f611bd6222eab52577182321 /net-im
parentb44ee89f34a7c7e3aa12653af69cbdeb99341525 (diff)
downloadports-62cdf18706b72387c5fb724c936e10440cdae823.tar.gz
ports-62cdf18706b72387c5fb724c936e10440cdae823.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/climm/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index 37109b8181f2..cb6458f2d4e2 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -12,8 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= johans@FreeBSD.org
COMMENT= CLI-based Multi-Messenger
-USES= pkgconfig
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,13 +27,12 @@ OTR_DESC= Enable OTR encryption support
REMOTE_DESC= Enable Remote control fifo support
XMPP_DESC= Enable XMPP Jabber support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOTR}
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-otr
-LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3
+LIB_DEPENDS+= libotr.so.4:${PORTSDIR}/security/libotr3
.else
CONFIGURE_ARGS+= --disable-otr
.endif
@@ -52,8 +50,7 @@ CONFIGURE_ARGS+= --disable-peer2peer
.endif
.if ${PORT_OPTIONS:MTCL}
-USE_TCL= yes
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+USES+= tcl
.else
CONFIGURE_ARGS+= --disable-tcl
.endif
@@ -69,10 +66,10 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-xmpp --enable-ssl=gnutls \
--with-libgcrypt-prefix=${LOCALBASE}
CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkgconf gnutls"
-LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
- gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error:${PORTSDIR}/security/libgpg-error
+LIB_DEPENDS+= libiksemel.so:${PORTSDIR}/textproc/iksemel \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
.else
USE_OPENSSL= yes
CONFIGURE_ARGS+= --disable-xmpp --enable-ssl=openssl
@@ -86,14 +83,12 @@ post-patch:
${WRKSRC}/configure
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/climm.1 ${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/climmrc.5 ${MANPREFIX}/man/man5
- ${INSTALL_MAN} ${WRKSRC}/doc/climmcmds.7 ${MANPREFIX}/man/man7
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-. for ext in i18n logformat png txt xpm
- ${INSTALL_DATA} ${WRKSRC}/doc/*.${ext} ${DOCSDIR}
-. endfor
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/doc/climm.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/climmrc.5 ${STAGEDIR}${PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/doc/climmcmds.7 ${STAGEDIR}${PREFIX}/man/man7
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for ext in i18n logformat png txt xpm
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.${ext} ${STAGEDIR}${DOCSDIR}
+.endfor
.include <bsd.port.mk>