aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-06-30 21:22:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-06-30 21:22:25 +0000
commit68e670f9e7033f5a4de5c83a41bb15a6a2af14cf (patch)
tree43621a8c85ec9d6a1ab841e54997660c2e102f30 /net-im
parent8a7f86cc7864e5435fbe89a7e827c734e34ebe17 (diff)
downloadports-68e670f9e7033f5a4de5c83a41bb15a6a2af14cf.tar.gz
ports-68e670f9e7033f5a4de5c83a41bb15a6a2af14cf.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/tox/Makefile8
-rw-r--r--net-im/tox/distinfo4
-rw-r--r--net-im/tox/pkg-plist5
-rw-r--r--net-im/toxic/Makefile20
-rw-r--r--net-im/toxic/distinfo4
-rw-r--r--net-im/toxic/files/pkg-message.in2
-rw-r--r--net-im/toxic/pkg-plist7
-rw-r--r--net-im/venom/Makefile6
-rw-r--r--net-im/venom/distinfo4
-rw-r--r--net-im/venom/pkg-plist2
10 files changed, 36 insertions, 26 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 2af9213c35a8..7cb77a9e1064 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -1,8 +1,8 @@
# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-PORTNAME= ProjectTox-Core
-PORTVERSION= 0.140611
+PORTNAME= toxcore
+PORTVERSION= 0.140630
CATEGORIES= net-im net-p2p
MAINTAINER= thierry@FreeBSD.org
@@ -19,9 +19,9 @@ LIB_DEPENDS= libvpx.so:${PORTSDIR}/multimedia/libvpx \
USE_GITHUB= yes
GH_ACCOUNT= irungentoo
-GH_PROJECT= ProjectTox-Core
+GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 63f25f8
+GH_COMMIT= 8f7638d
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
AUTOMAKE_ARGS= -a -c -f
diff --git a/net-im/tox/distinfo b/net-im/tox/distinfo
index 6af1d2a3efab..502e0490b3e6 100644
--- a/net-im/tox/distinfo
+++ b/net-im/tox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ProjectTox-Core-0.140611.tar.gz) = 86b3576a705742153f18a5ccb77b9506d4fc2ee505620da6271c907d716b8ea4
-SIZE (ProjectTox-Core-0.140611.tar.gz) = 269950
+SHA256 (toxcore-0.140630.tar.gz) = f904883298dade37f15018b4bead9bf164450d62c1694c2a2cefb830abb56c7b
+SIZE (toxcore-0.140630.tar.gz) = 277832
diff --git a/net-im/tox/pkg-plist b/net-im/tox/pkg-plist
index 995b756ce2a4..8c1cabb4055b 100644
--- a/net-im/tox/pkg-plist
+++ b/net-im/tox/pkg-plist
@@ -1,6 +1,7 @@
bin/DHT_bootstrap
include/tox/tox.h
include/tox/toxav.h
+include/tox/toxdns.h
lib/libtoxav.a
%%SODIUM%%lib/libtoxav.so
%%SODIUM%%lib/libtoxav.so.0
@@ -9,6 +10,10 @@ lib/libtoxcore.a
%%SODIUM%%lib/libtoxcore.so
%%SODIUM%%lib/libtoxcore.so.0
%%SODIUM%%lib/libtoxcore.so.0.0.0
+lib/libtoxdns.a
+%%SODIUM%%lib/libtoxdns.so
+%%SODIUM%%lib/libtoxdns.so.0
+%%SODIUM%%lib/libtoxdns.so.0.0.0
libdata/pkgconfig/libtoxav.pc
libdata/pkgconfig/libtoxcore.pc
@dirrm include/tox
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index 5a1e915ad4bc..93125992dbf4 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= toxic
-PORTVERSION= 0.4.0.140611
+PORTVERSION= 0.4.2.140630
CATEGORIES= net-im
MAINTAINER= thierry@FreeBSD.org
@@ -19,13 +19,15 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tox
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 328e7f8
+GH_COMMIT= a126f9c
WRKSRC= ${WRKDIR}/Tox-${PORTNAME}-${GH_COMMIT}
+BUILD_WRKSRC= ${WRKSRC}/build
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+MAKE_ENV= USER_CFLAGS="${CFLAGS}" USER_LDFLAGS="${LDFLAGS}"
SUB_FILES= pkg-message
-USES= ncurses:port pkgconfig
-USE_AUTOTOOLS= autoconf aclocal
+USES= ncurses:port gmake pkgconfig
.include <bsd.port.pre.mk>
@@ -34,13 +36,11 @@ USE_BINUTILS= yes
LDFLAGS+= -B${LOCALBASE}/bin
.endif
-run-autotools:
- cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${AUTORECONF} -if
+pre-configure:
+ ${REINPLACE_CMD} -e 's|PREFIX =|PREFIX?=|;s|$$(shell git rev-list HEAD --count)|${GH_COMMIT}|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/misc/toxic.conf ${STAGEDIR}${EXAMPLESDIR}
-.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/toxic
.include <bsd.port.post.mk>
diff --git a/net-im/toxic/distinfo b/net-im/toxic/distinfo
index 5003ce03b8da..408582e49473 100644
--- a/net-im/toxic/distinfo
+++ b/net-im/toxic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (toxic-0.4.0.140611.tar.gz) = 3124965b56a4ed42b80af08f58a126d8c4f0035084393bcf9297b35290f1994f
-SIZE (toxic-0.4.0.140611.tar.gz) = 78177
+SHA256 (toxic-0.4.2.140630.tar.gz) = 64551ccf2cea7c5c8ebe47ddffbd06b8ace5e1da155895f1370b0dd1be3e1fc4
+SIZE (toxic-0.4.2.140630.tar.gz) = 70949
diff --git a/net-im/toxic/files/pkg-message.in b/net-im/toxic/files/pkg-message.in
index d22a4177879a..8836ab80d583 100644
--- a/net-im/toxic/files/pkg-message.in
+++ b/net-im/toxic/files/pkg-message.in
@@ -7,7 +7,7 @@
colour_theme:1;
in your ~/.config/tox/toxic.conf
- (more parameters available - see %%EXAMPLESDIR%%/toxic.conf )
+ (more parameters available - see %%DATADIR%%/toxic.conf.example )
or try to define another TERM, e.g.:
TERM=vt100 toxic
diff --git a/net-im/toxic/pkg-plist b/net-im/toxic/pkg-plist
index 0a417f0fbce7..233299f7637d 100644
--- a/net-im/toxic/pkg-plist
+++ b/net-im/toxic/pkg-plist
@@ -1,5 +1,8 @@
bin/toxic
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/toxic.conf
+man/man1/toxic.1-e.gz
+man/man1/toxic.1.gz
+man/man5/toxic.conf.5-e.gz
+man/man5/toxic.conf.5.gz
%%DATADIR%%/DHTnodes
+%%DATADIR%%/toxic.conf.example
@dirrm %%DATADIR%%
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/net-im/venom/Makefile b/net-im/venom/Makefile
index fc5f1601b80d..6ecadfde392d 100644
--- a/net-im/venom/Makefile
+++ b/net-im/venom/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Venom
-PORTVERSION= 0.2.0.140611
+PORTVERSION= 0.2.0.140630
CATEGORIES= net-im
MAINTAINER= thierry@FreeBSD.org
@@ -19,9 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= naxuroqa
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 91b1f35
+GH_COMMIT= dd91b7c
-USES= cmake desktop-file-utils pkgconfig
+USES= cmake desktop-file-utils pkgconfig gettext
USE_GNOME= glib20 gtk30
USE_SQLITE= yes
INSTALLS_ICONS= yes
diff --git a/net-im/venom/distinfo b/net-im/venom/distinfo
index a9087d6e8d68..1473da2f6d43 100644
--- a/net-im/venom/distinfo
+++ b/net-im/venom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Venom-0.2.0.140611.tar.gz) = 6b6c0422531d207761553950c06e4f84638e32d46cdfc8f14e29402bb1374fbb
-SIZE (Venom-0.2.0.140611.tar.gz) = 148241
+SHA256 (Venom-0.2.0.140630.tar.gz) = b3274853ffec0282472175179292d124984b80e8c495124c22f5bae06b5b8629
+SIZE (Venom-0.2.0.140630.tar.gz) = 163496
diff --git a/net-im/venom/pkg-plist b/net-im/venom/pkg-plist
index c5c20c6cb92c..4fb5d4da56ae 100644
--- a/net-im/venom/pkg-plist
+++ b/net-im/venom/pkg-plist
@@ -7,6 +7,8 @@ share/icons/hicolor/32x32/apps/venom.png
share/icons/hicolor/48x48/apps/venom.png
share/icons/hicolor/64x64/apps/venom.png
share/icons/hicolor/scalable/apps/venom.svg
+share/locale/de/LC_MESSAGES/Venom.mo
+share/locale/it/LC_MESSAGES/Venom.mo
share/pixmaps/venom.png
share/venom/theme/default.css
@dirrmtry share/venom/theme