aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-20 16:51:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-20 16:51:03 +0000
commita437d2d330fdddc302d8fa3982abf86950bcb361 (patch)
tree2571da61375b7eb3b1a8501dcdb0c473f61f85ed /net-im
parent6a6a06117ad434ea03d9502b7efb051a9e41b22c (diff)
downloadports-a437d2d330fdddc302d8fa3982abf86950bcb361.tar.gz
ports-a437d2d330fdddc302d8fa3982abf86950bcb361.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-pyicq/Makefile14
-rw-r--r--net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in2
2 files changed, 14 insertions, 2 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index b8056b609fff..ef304906fda6 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -20,6 +20,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-op
${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+OPTIONS= EJABBERD "Use transport with ejabberd" off
+
NO_BUILD= yes
USE_PYTHON= yes
USE_RC_SUBR= jabber-pyicq-transport.sh
@@ -31,6 +33,16 @@ INST_DIR= ${PREFIX}/lib/jabber/${PORTNAME}
PORTDOCS= COPYING README NEWS
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EJABBERD)
+JABBER_USER?= ejabberd
+.else
+JABBER_USER?= jabber
+.endif
+
+SUB_LIST+= JABBER_USER=${JABBER_USER}
+
post-extract:
@${FIND} ${WRKSRC}/src -type d -name '.svn' | ${XARGS} ${RM} -rf
@@ -65,4 +77,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
index c9bdfe44afc6..11c95414e19b 100644
--- a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
+++ b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
@@ -22,7 +22,7 @@ load_rc_config $name
: ${jabber_pyicq_enable="NO"}
: ${jabber_pyicq_dir="%%PREFIX%%/lib/jabber/pyicq"}
: ${jabber_pyicq_piddir="/var/jabberd/pid"}
-: ${jabber_pyicq_user="jabber"}
+: ${jabber_pyicq_user="%%JABBER_USER%%"}
pidfile="${jabber_pyicq_piddir}/PyICQt.pid"
command_interpreter="%%PYTHON_CMD%%"