aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
commitaa7a6c429ea62d972467d6755fa7a6f52256b452 (patch)
tree3c451883d3bd4d2ffe401b2b6aee58825505d145 /net-im
parentc3b3e6a10d663bc2672cdd4bf46943046d03ecba (diff)
downloadports-aa7a6c429ea62d972467d6755fa7a6f52256b452.tar.gz
ports-aa7a6c429ea62d972467d6755fa7a6f52256b452.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/py-fbmq/Makefile2
-rw-r--r--net-im/py-nbxmpp/Makefile2
-rw-r--r--net-im/py-punjab/Makefile2
-rw-r--r--net-im/py-python-telegram-bot/Makefile2
-rw-r--r--net-im/py-telepot/Makefile2
-rw-r--r--net-im/py-toxcore-c/Makefile2
-rw-r--r--net-im/py-unmessage/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/net-im/py-fbmq/Makefile b/net-im/py-fbmq/Makefile
index f992c55f805d..cff2a0564dc0 100644
--- a/net-im/py-fbmq/Makefile
+++ b/net-im/py-fbmq/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/net-im/py-nbxmpp/Makefile b/net-im/py-nbxmpp/Makefile
index 24f5564f043e..fca8ec9daf9b 100644
--- a/net-im/py-nbxmpp/Makefile
+++ b/net-im/py-nbxmpp/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/net-im/py-punjab/Makefile b/net-im/py-punjab/Makefile
index 243c1e307078..c0da1db3a050 100644
--- a/net-im/py-punjab/Makefile
+++ b/net-im/py-punjab/Makefile
@@ -13,7 +13,7 @@ COMMENT= HTTP XMPP client interface
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
USE_RC_SUBR= punjab
diff --git a/net-im/py-python-telegram-bot/Makefile b/net-im/py-python-telegram-bot/Makefile
index 267f1247c3b5..0afea2dc52d1 100644
--- a/net-im/py-python-telegram-bot/Makefile
+++ b/net-im/py-python-telegram-bot/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
PYDISTUTILS_BUILDARGS= --with-upstream-urllib3
diff --git a/net-im/py-telepot/Makefile b/net-im/py-telepot/Makefile
index 4100133de79d..66c9a1871121 100644
--- a/net-im/py-telepot/Makefile
+++ b/net-im/py-telepot/Makefile
@@ -13,7 +13,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urllib3>=1.9.1:net/py-urllib3@${PY_FLAVOR}
-USES= dos2unix python
+USES= dos2unix python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/net-im/py-toxcore-c/Makefile b/net-im/py-toxcore-c/Makefile
index db7cd5057365..a2480eb45504 100644
--- a/net-im/py-toxcore-c/Makefile
+++ b/net-im/py-toxcore-c/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libtoxcore.so:net-im/tox \
libvpx.so:multimedia/libvpx \
libopus.so:audio/opus
-USES= localbase python
+USES= localbase python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= TokTok
GH_PROJECT= py-toxcore-c
diff --git a/net-im/py-unmessage/Makefile b/net-im/py-unmessage/Makefile
index f11a62c861eb..6fe2d9a61af3 100644
--- a/net-im/py-unmessage/Makefile
+++ b/net-im/py-unmessage/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FL
${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=0.6:dns/py-idna@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes