aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-05-10 11:53:40 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-05-10 11:53:40 +0000
commite0d196a5cba5e8727b630a1ea454ebdf87e27c86 (patch)
treee1e6a77afb65a52300c63ffafc1536d8c2cddce7 /net-im
parent67afec1e07cd293852f539440baa77bad1eb1216 (diff)
downloadports-e0d196a5cba5e8727b630a1ea454ebdf87e27c86.tar.gz
ports-e0d196a5cba5e8727b630a1ea454ebdf87e27c86.zip
Do not try to send the credentials full JID since jabber servers
only expect the JID user node. Submitted by: colby.dillion@gmail.com Obtained from: google-talk-open newsgroup
Notes
Notes: svn path=/head/; revision=161918
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libjingle/Makefile2
-rw-r--r--net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-im/libjingle/Makefile b/net-im/libjingle/Makefile
index b8d56b442f85..b7be6bb4fe20 100644
--- a/net-im/libjingle/Makefile
+++ b/net-im/libjingle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libjingle
PORTVERSION= 0.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h b/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h
new file mode 100644
index 000000000000..b6892aa4e16c
--- /dev/null
+++ b/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h
@@ -0,0 +1,11 @@
+--- talk/xmpp/saslplainmechanism.h.orig Wed May 10 07:43:35 2006
++++ talk/xmpp/saslplainmechanism.h Wed May 10 07:44:01 2006
+@@ -48,7 +48,7 @@
+
+ FormatXmppPassword credential;
+ credential.Append("\0", 1);
+- credential.Append(user_jid_.Str());
++ credential.Append(user_jid_.node());
+ credential.Append("\0", 1);
+ credential.Append(&password_);
+ el->AddText(Base64EncodeFromArray(credential.GetData(), credential.GetLength()));