aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-15 12:05:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-15 12:05:45 +0000
commitf587997497991bc5c1021135a155bc6507c31a0e (patch)
tree10c0649177106ce33762f47e3737fa9c5cfa83ae /net-im
parent5f4b5ef6da3654d3f2c79ac66a0d26fce357b801 (diff)
downloadports-f587997497991bc5c1021135a155bc6507c31a0e.tar.gz
ports-f587997497991bc5c1021135a155bc6507c31a0e.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pino/Makefile39
-rw-r--r--net-im/pino/distinfo3
-rw-r--r--net-im/pino/pkg-descr5
-rw-r--r--net-im/pino/pkg-plist49
5 files changed, 97 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index ee7cce2011e6..a4eead8bebb1 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -124,6 +124,7 @@
SUBDIR += pidgin-rhythmbox
SUBDIR += pidgin-sipe
SUBDIR += pidgin-twitter
+ SUBDIR += pino
SUBDIR += pork
SUBDIR += prosody
SUBDIR += psi
diff --git a/net-im/pino/Makefile b/net-im/pino/Makefile
new file mode 100644
index 000000000000..8e8cc0d1700e
--- /dev/null
+++ b/net-im/pino/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pino
+# Date created: 2010-03-14
+# Whom: Frank Steinborn <steinex@nognu.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pino
+PORTVERSION= 0.2.1
+CATEGORIES= net-im
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= steinex@nognu.de
+COMMENT= A simple and fast Twitter and Identi.ca client
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee \
+ notify.1:${PORTSDIR}/devel/libnotify \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
+ webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+
+PROJECTHOST= pino-twitter
+USE_GNOME= gnomehack intltool libxml2 gtk20 glib20
+USE_GETTEXT= yes
+USE_PYTHON_BUILD= yes
+USE_BZIP2= yes
+INSTALLS_ICONS= yes
+
+do-configure:
+ @cd ${WRKSRC} && ./waf configure --prefix="${PREFIX}"
+
+do-build:
+ @cd ${WRKSRC} && ./waf build
+
+do-install:
+ @cd ${WRKSRC} && ./waf install
+
+.include <bsd.port.mk>
diff --git a/net-im/pino/distinfo b/net-im/pino/distinfo
new file mode 100644
index 000000000000..b7a82d029856
--- /dev/null
+++ b/net-im/pino/distinfo
@@ -0,0 +1,3 @@
+MD5 (pino-0.2.1.tar.bz2) = caea49bfdf294963fd2744581c62be48
+SHA256 (pino-0.2.1.tar.bz2) = 42a5fc9b56496fbcb1e218f06ccb71e6c40fc00c8c906649158b8bd813d1c9dc
+SIZE (pino-0.2.1.tar.bz2) = 173163
diff --git a/net-im/pino/pkg-descr b/net-im/pino/pkg-descr
new file mode 100644
index 000000000000..026d186e74d8
--- /dev/null
+++ b/net-im/pino/pkg-descr
@@ -0,0 +1,5 @@
+Pino is a simple and fast Twitter and Identi.ca client using GTK2.
+It is written in Vala language and compiled to the native binary
+code.
+
+WWW: http://pino-app.appspot.com/
diff --git a/net-im/pino/pkg-plist b/net-im/pino/pkg-plist
new file mode 100644
index 000000000000..c79d0cc7f84d
--- /dev/null
+++ b/net-im/pino/pkg-plist
@@ -0,0 +1,49 @@
+bin/pino
+share/applications/pino.desktop
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/README
+share/icons/hicolor/scalable/apps/pino.svg
+share/icons/hicolor/scalable/apps/pino_fresh.svg
+share/locale/ar/LC_MESSAGES/pino.mo
+share/locale/cs/LC_MESSAGES/pino.mo
+share/locale/de/LC_MESSAGES/pino.mo
+share/locale/es/LC_MESSAGES/pino.mo
+share/locale/fr/LC_MESSAGES/pino.mo
+share/locale/gl/LC_MESSAGES/pino.mo
+share/locale/it/LC_MESSAGES/pino.mo
+share/locale/ko_KR/LC_MESSAGES/pino.mo
+share/locale/lv/LC_MESSAGES/pino.mo
+share/locale/nl/LC_MESSAGES/pino.mo
+share/locale/pl/LC_MESSAGES/pino.mo
+share/locale/pt/LC_MESSAGES/pino.mo
+share/locale/pt_BR/LC_MESSAGES/pino.mo
+share/locale/ru/LC_MESSAGES/pino.mo
+share/locale/sv/LC_MESSAGES/pino.mo
+share/locale/th/LC_MESSAGES/pino.mo
+share/locale/uk/LC_MESSAGES/pino.mo
+share/locale/zh_CN/LC_MESSAGES/pino.mo
+%%DATADIR%%/icons/delete_status.png
+%%DATADIR%%/icons/direct.svg
+%%DATADIR%%/icons/direct_fresh.svg
+%%DATADIR%%/icons/direct_reply.png
+%%DATADIR%%/icons/mentions.svg
+%%DATADIR%%/icons/mentions_fresh.svg
+%%DATADIR%%/icons/progress.gif
+%%DATADIR%%/icons/re_tweet.png
+%%DATADIR%%/icons/reply.png
+%%DATADIR%%/icons/timeline.svg
+%%DATADIR%%/icons/timeline_fresh.svg
+%%DATADIR%%/icons/userpic.svg
+%%DATADIR%%/templates/main.tpl
+%%DATADIR%%/templates/status.tpl
+%%DATADIR%%/templates/status_direct.tpl
+%%DATADIR%%/templates/status_me.tpl
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%
+@dirrmtry share/locale/ko_KR/LC_MESSAGES
+@dirrmtry share/locale/ko_KR
+@dirrmtry share/applications