aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/2ping
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:21:18 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:21:18 +0000
commitc7d7d1dfac9a927ba7143accf1748c79f48cc07a (patch)
treec4a28ae07de35398ee7ef6add376ff13bf618674 /net-mgmt/2ping
parent0b782615290dcad70a67bd2d0c39e1035bcb9678 (diff)
downloadports-c7d7d1dfac9a927ba7143accf1748c79f48cc07a.tar.gz
ports-c7d7d1dfac9a927ba7143accf1748c79f48cc07a.zip
2ping is a bi-directional ping utility. It uses 3-way pings (akin to
TCP SYN, SYN/ACK, ACK) and after-the-fact state comparison between a 2ping listener and a 2ping client to determine which direction packet loss occurs. WWW: http://www.finnie.org/software/2ping/ PR: ports/152528 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=265055
Diffstat (limited to 'net-mgmt/2ping')
-rw-r--r--net-mgmt/2ping/Makefile25
-rw-r--r--net-mgmt/2ping/distinfo2
-rw-r--r--net-mgmt/2ping/files/patch-Makefile17
-rw-r--r--net-mgmt/2ping/pkg-descr6
-rw-r--r--net-mgmt/2ping/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/net-mgmt/2ping/Makefile b/net-mgmt/2ping/Makefile
new file mode 100644
index 000000000000..ab6ed4f9c911
--- /dev/null
+++ b/net-mgmt/2ping/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: 2ping
+# Date created: 2010-11-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 2ping
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= http://www.finnie.org/software/2ping/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A bi-directional ping utility
+
+RUN_DEPENDS= p5-Digest-CRC>=0:${PORTSDIR}/security/p5-Digest-CRC \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
+
+USE_PERL5_RUN= 5.8.0+
+
+MAN8= 2ping.8 2ping6.8
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/2ping/distinfo b/net-mgmt/2ping/distinfo
new file mode 100644
index 000000000000..84c774eacb31
--- /dev/null
+++ b/net-mgmt/2ping/distinfo
@@ -0,0 +1,2 @@
+SHA256 (2ping-1.0.tar.gz) = f6658d6994260de274a5aa490d56d6ab77cebb86020ce1d75ed218c63b595903
+SIZE (2ping-1.0.tar.gz) = 30280
diff --git a/net-mgmt/2ping/files/patch-Makefile b/net-mgmt/2ping/files/patch-Makefile
new file mode 100644
index 000000000000..a0e455186b56
--- /dev/null
+++ b/net-mgmt/2ping/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig 2010-11-23 22:18:10.000000000 +0800
++++ Makefile 2010-11-23 22:19:16.000000000 +0800
+@@ -34,11 +34,11 @@
+
+ install: all
+ install -d -m 0755 $(DESTDIR)$(PREFIX)/bin
+- install -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man8
++ install -d -m 0755 $(DESTDIR)$(PREFIX)/man/man8
+ install -m 0755 2ping $(DESTDIR)$(PREFIX)/bin
+ ln -sf 2ping $(DESTDIR)$(PREFIX)/bin/2ping6
+- install -m 0644 2ping.8 $(DESTDIR)$(PREFIX)/share/man/man8
+- ln -sf 2ping.8 $(DESTDIR)$(PREFIX)/share/man/man8/2ping6.8
++ install -m 0644 2ping.8 $(DESTDIR)$(PREFIX)/man/man8
++ cp $(DESTDIR)$(PREFIX)/man/man8/2ping.8 $(DESTDIR)$(PREFIX)/man/man8/2ping6.8
+
+ distclean: clean
+
diff --git a/net-mgmt/2ping/pkg-descr b/net-mgmt/2ping/pkg-descr
new file mode 100644
index 000000000000..35d3c9cd86ea
--- /dev/null
+++ b/net-mgmt/2ping/pkg-descr
@@ -0,0 +1,6 @@
+2ping is a bi-directional ping utility. It uses 3-way pings (akin to
+TCP SYN, SYN/ACK, ACK) and after-the-fact state comparison between a
+2ping listener and a 2ping client to determine which direction packet
+loss occurs.
+
+WWW: http://www.finnie.org/software/2ping/
diff --git a/net-mgmt/2ping/pkg-plist b/net-mgmt/2ping/pkg-plist
new file mode 100644
index 000000000000..2bd96cc51ab0
--- /dev/null
+++ b/net-mgmt/2ping/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+bin/2ping
+bin/2ping6