aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/aircrack-ng/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-04-01 17:34:36 +0000
committerLars Engels <lme@FreeBSD.org>2014-04-01 17:34:36 +0000
commit6e2d7f311b8526db91d9cc944ef60a49289c6f0a (patch)
treeabdf6db612b2ed492ebb97921632608100fc5701 /net-mgmt/aircrack-ng/Makefile
parent1d5bc57c30cd8e69e7b74d727474f372b30adb69 (diff)
downloadports-6e2d7f311b8526db91d9cc944ef60a49289c6f0a.tar.gz
ports-6e2d7f311b8526db91d9cc944ef60a49289c6f0a.zip
Notes
Diffstat (limited to 'net-mgmt/aircrack-ng/Makefile')
-rw-r--r--net-mgmt/aircrack-ng/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
index f0bb4055b29e..19a5f529b90f 100644
--- a/net-mgmt/aircrack-ng/Makefile
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -2,22 +2,20 @@
# $FreeBSD$
PORTNAME= aircrack-ng
-DISTVERSION= 1.2b2
-PORTREVISION= 2
+DISTVERSION= 1.2-beta3
CATEGORIES= net-mgmt security
MASTER_SITES= http://download.aircrack-ng.org/ \
http://bsd-geek.de/FreeBSD/distfiles/
-DISTNAME= ${PORTNAME}-${DISTVERSION:C/b/-beta/}
MAINTAINER= lme@FreeBSD.org
-COMMENT= An 802.11 WEP and WPA-PSK keys cracking program
+COMMENT= 802.11 WEP and WPA-PSK keys cracking program
LICENSE= GPLv2 BSD3CLAUSE APACHE20
LICENSE_COMB= dual
USES= gmake dos2unix
DOS2UNIX_FILES= src/osdep/byteorder.h
-MAKE_ARGS+= unstable=true prefix=${PREFIX}
+MAKE_ARGS= unstable=true libnl=false prefix=${PREFIX}
USE_OPENSSL= yes
SUB_FILES= pkg-message
@@ -38,13 +36,6 @@ MAKE_ARGS+= SQLITE=true
BIN_FILES+= airolib-ng
.endif
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
-.if ${ARCH} == "sparc64" && ${OSVERSION} > 900000
-BROKEN= Does not compile on sparc64-9
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's|-I/usr/local|-I${LOCALBASE}|' \
@@ -62,12 +53,9 @@ post-patch:
@${REINPLACE_CMD} \
-e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/src/Makefile
+
post-install:
-.for f in ${BIN_FILES}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/$f
-.endfor
-.for f in ${SBIN_FILES}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/$f
-.endfor
+ @${STRIP_CMD} ${BIN_FILES:S,^,${STAGEDIR}${PREFIX}/bin/,} \
+ ${SBIN_FILES:S,^,${STAGEDIR}${PREFIX}/sbin/,}
.include <bsd.port.mk>