aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ap-utils
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-05-30 08:05:02 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-05-30 08:05:02 +0000
commitd225bee350a699ef6ef6b4058707678fe864bddf (patch)
tree52ddeb4ade035bde24997e7f31d795a345c53be0 /net-mgmt/ap-utils
parentdcf4376fac4505a709058e0cff2aea384eeff4d8 (diff)
downloadports-d225bee350a699ef6ef6b4058707678fe864bddf.tar.gz
ports-d225bee350a699ef6ef6b4058707678fe864bddf.zip
- Stage support
- Use options hepers where possible Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=355799
Diffstat (limited to 'net-mgmt/ap-utils')
-rw-r--r--net-mgmt/ap-utils/Makefile30
-rw-r--r--net-mgmt/ap-utils/files/patch-configure36
-rw-r--r--net-mgmt/ap-utils/files/patch-lib__ap_search.c (renamed from net-mgmt/ap-utils/files/patch-aa)4
-rw-r--r--net-mgmt/ap-utils/pkg-plist3
4 files changed, 51 insertions, 22 deletions
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index 426f8bf2910c..823d45d24a82 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -5,42 +5,32 @@ PORTNAME= ap-utils
PORTVERSION= 1.4.1
PORTREVISION= 4
CATEGORIES= net-mgmt
-MASTER_SITES= SF
+MASTER_SITES= SF
MAINTAINER= david@catwhisker.org
-COMMENT= A set of utilities to configure and monitor wireless access points
+COMMENT= Set of utilities to configure and monitor wireless access points
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USES= iconv
+USES= iconv tar:bzip2
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lintl -L${LOCALBASE}/lib
-MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
-
-NO_STAGE= yes
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_WITHOUT= --disable-nls
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
+.if ! ${PORT_OPTIONS:MNLS}
BROKEN= Does not build without gettext
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
-
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/Documentation && \
- ${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-mgmt/ap-utils/files/patch-configure b/net-mgmt/ap-utils/files/patch-configure
new file mode 100644
index 000000000000..f4cdb1e648d8
--- /dev/null
+++ b/net-mgmt/ap-utils/files/patch-configure
@@ -0,0 +1,36 @@
+--- ./configure.orig 2004-05-16 14:10:31.000000000 +0000
++++ ./configure 2014-05-30 08:01:14.000000000 +0000
+@@ -6840,7 +6840,6 @@
+ /* end confdefs.h. */
+ #include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+@@ -6850,7 +6849,7 @@
+ main ()
+ {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
++return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_expand_alias (0)
+ ;
+ return 0;
+ }
+@@ -6886,7 +6885,6 @@
+ /* end confdefs.h. */
+ #include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+@@ -6896,7 +6894,7 @@
+ main ()
+ {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
++return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_expand_alias (0)
+ ;
+ return 0;
+ }
diff --git a/net-mgmt/ap-utils/files/patch-aa b/net-mgmt/ap-utils/files/patch-lib__ap_search.c
index 905bb9385afa..0142c8e7fd58 100644
--- a/net-mgmt/ap-utils/files/patch-aa
+++ b/net-mgmt/ap-utils/files/patch-lib__ap_search.c
@@ -1,5 +1,5 @@
---- lib/ap_search.c.orig Tue May 4 11:18:09 2004
-+++ lib/ap_search.c Fri Jul 30 22:29:37 2004
+--- ./lib/ap_search.c.orig 2004-05-04 15:18:09.000000000 +0000
++++ ./lib/ap_search.c 2014-05-30 08:01:14.000000000 +0000
@@ -34,6 +34,7 @@
#include <sys/socket.h>
#endif
diff --git a/net-mgmt/ap-utils/pkg-plist b/net-mgmt/ap-utils/pkg-plist
index 3964ed1dc7bc..8609d1ea9cbb 100644
--- a/net-mgmt/ap-utils/pkg-plist
+++ b/net-mgmt/ap-utils/pkg-plist
@@ -1,6 +1,9 @@
bin/ap-config
bin/ap-mrtg
bin/ap-gl
+man/man8/ap-trapd.8.gz
+man/man8/ap-mrtg.8.gz
+man/man8/ap-config.8.gz
sbin/ap-trapd
%%NLS%%share/locale/fr/LC_MESSAGES/ap-utils.mo
%%NLS%%share/locale/nl/LC_MESSAGES/ap-utils.mo