aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/arpscan
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-23 08:49:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-23 08:49:46 +0000
commit96b9b05411d41973fc133f46d73ae6a5cf1779eb (patch)
tree95f19fa89fb4335106def07fe95077fd83f9085e /net-mgmt/arpscan
parent87ab2e83a0335c3a045320728b2ceb3afce9f5ea (diff)
downloadports-96b9b05411d41973fc133f46d73ae6a5cf1779eb.tar.gz
ports-96b9b05411d41973fc133f46d73ae6a5cf1779eb.zip
Add arpscan-0.2,
arpscan is a very simple scanner which sends out arp requests for the given IP addresses and displays a list of the found hosts. PR: ports/64605 Submitted by: David Yeske <dyeske@yahoo.com>
Notes
Notes: svn path=/head/; revision=105020
Diffstat (limited to 'net-mgmt/arpscan')
-rw-r--r--net-mgmt/arpscan/Makefile29
-rw-r--r--net-mgmt/arpscan/distinfo2
-rw-r--r--net-mgmt/arpscan/files/patch-arpscan.c16
-rw-r--r--net-mgmt/arpscan/pkg-descr7
4 files changed, 54 insertions, 0 deletions
diff --git a/net-mgmt/arpscan/Makefile b/net-mgmt/arpscan/Makefile
new file mode 100644
index 000000000000..8642bcc75a4b
--- /dev/null
+++ b/net-mgmt/arpscan/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: arpscan
+# Date created: 22 Mar 2004
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arpscan
+PORTVERSION= 0.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://ish.cx/~jason/arpscan/
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= Simple arp scanner
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PLIST_FILES= bin/arpscan
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 500000
+IGNORE= "unknown BIOCSETIF error"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/arpscan/distinfo b/net-mgmt/arpscan/distinfo
new file mode 100644
index 000000000000..2840d6727b17
--- /dev/null
+++ b/net-mgmt/arpscan/distinfo
@@ -0,0 +1,2 @@
+MD5 (arpscan-0.2.tar.gz) = a832c8946dc9e2d66c8fa02a7a8b8059
+SIZE (arpscan-0.2.tar.gz) = 35462
diff --git a/net-mgmt/arpscan/files/patch-arpscan.c b/net-mgmt/arpscan/files/patch-arpscan.c
new file mode 100644
index 000000000000..465a2f1e71f7
--- /dev/null
+++ b/net-mgmt/arpscan/files/patch-arpscan.c
@@ -0,0 +1,16 @@
+--- arpscan.c.orig Mon Aug 18 16:54:25 2003
++++ arpscan.c Mon Mar 22 23:05:40 2004
+@@ -17,6 +17,13 @@
+
+ #define PCAP_TIMEO 20
+
++#ifdef __FreeBSD__
++# include <sys/param.h>
++# if __FreeBSD_version > 500000
++# define NTOHL(x) (x) = ntohl((u_int32_t)(x))
++# endif
++#endif
++
+ struct ether_arp {
+ struct arp_hdr ea_hdr;
+ u_int8_t arp_sha[ETH_ADDR_LEN];
diff --git a/net-mgmt/arpscan/pkg-descr b/net-mgmt/arpscan/pkg-descr
new file mode 100644
index 000000000000..f06809b25641
--- /dev/null
+++ b/net-mgmt/arpscan/pkg-descr
@@ -0,0 +1,7 @@
+arpscan is a very simple scanner which sends out arp requests for
+the given IP addresses and displays a list of the found hosts.
+
+WWW: http://ish.cx/~jason/arpscan/
+
+- David
+dyeske@yahoo.com