aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bandwidthd
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-11 20:59:54 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-11 20:59:54 +0000
commit7e7e9e128d05a3e6851562b6d38ad85d7acb9e3e (patch)
tree8cdf31f672c70f9ebe5e60f5905f56e88235889c /net-mgmt/bandwidthd
parent8c4ed76f235e80b200a010eaa4c2e4f219bbfd00 (diff)
downloadports-7e7e9e128d05a3e6851562b6d38ad85d7acb9e3e.tar.gz
ports-7e7e9e128d05a3e6851562b6d38ad85d7acb9e3e.zip
- Update to version 1.1.6
Changes: The buggy sort algorithm has been replaced. The contents of the log file are loaded back into bandwidthd on restart, so data is persistent between restarts. Log rotation has been added. RecoverCdf has been modified to load large log files much faster, and to load files from the rotation. A segmentation fault in DropOldData has been fixed. PR: 59175 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=93751
Diffstat (limited to 'net-mgmt/bandwidthd')
-rw-r--r--net-mgmt/bandwidthd/Makefile2
-rw-r--r--net-mgmt/bandwidthd/distinfo2
-rw-r--r--net-mgmt/bandwidthd/files/patch-bandwidthd.c12
3 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/bandwidthd/Makefile b/net-mgmt/bandwidthd/Makefile
index 5108087e7207..d84d37927cb3 100644
--- a/net-mgmt/bandwidthd/Makefile
+++ b/net-mgmt/bandwidthd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bandwidthd
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.6
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-mgmt/bandwidthd/distinfo b/net-mgmt/bandwidthd/distinfo
index 62384ea9d752..ef4c6fdaf68f 100644
--- a/net-mgmt/bandwidthd/distinfo
+++ b/net-mgmt/bandwidthd/distinfo
@@ -1 +1 @@
-MD5 (bandwidthd-1.1.5.tgz) = a1376f78f7f3414bb95ce76f1a9deac7
+MD5 (bandwidthd-1.1.6.tgz) = 0255e5c61cacf0e283da620c2e8ec712
diff --git a/net-mgmt/bandwidthd/files/patch-bandwidthd.c b/net-mgmt/bandwidthd/files/patch-bandwidthd.c
index 966db7208556..7b39e3104885 100644
--- a/net-mgmt/bandwidthd/files/patch-bandwidthd.c
+++ b/net-mgmt/bandwidthd/files/patch-bandwidthd.c
@@ -1,6 +1,6 @@
---- bandwidthd.c.orig Fri Oct 10 20:22:39 2003
-+++ bandwidthd.c Sun Nov 2 12:21:17 2003
-@@ -114,7 +114,11 @@
+--- bandwidthd.c.orig Mon Nov 10 17:16:04 2003
++++ bandwidthd.c Tue Nov 11 13:52:27 2003
+@@ -129,7 +129,11 @@
}
else
{
@@ -12,12 +12,12 @@
exit(1);
}
}
-@@ -244,7 +248,7 @@
+@@ -264,7 +268,7 @@
tcp = (struct tcphdr *)(ip+1);
tcp = (struct tcphdr *) ( ((char *)tcp) + ((ip->ip_hl-5)*4) ); // Compensate for IP Options
Stats->tcp += size;
--#ifdef SOLARIS
-+#if defined(SOLARIS) || defined(FREEBSD)
+-#if defined(SOLARIS)
++#if defined(SOLARIS) || defined (FREEBSD)
sport = ntohs(tcp->th_sport);
dport = ntohs(tcp->th_dport);
#else