aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bsnmp-regex
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 19:43:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 19:43:07 +0000
commitdec0c907495c7670b36a602782fe9fd49663b185 (patch)
treed3495ea428f8506ec3d8fea3dc51d38d92095ede /net-mgmt/bsnmp-regex
parent5090cd21d581c8a8db0d2ea587c1743f945cbcf5 (diff)
downloadports-dec0c907495c7670b36a602782fe9fd49663b185.tar.gz
ports-dec0c907495c7670b36a602782fe9fd49663b185.zip
- Add option to use PCRE regex library
PR: 144832 Submitted by: Marko Njezic <mrmax063@maxempire.com> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=255826
Diffstat (limited to 'net-mgmt/bsnmp-regex')
-rw-r--r--net-mgmt/bsnmp-regex/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net-mgmt/bsnmp-regex/Makefile b/net-mgmt/bsnmp-regex/Makefile
index 160865c57a4f..951fefbdb4d1 100644
--- a/net-mgmt/bsnmp-regex/Makefile
+++ b/net-mgmt/bsnmp-regex/Makefile
@@ -15,6 +15,17 @@ COMMENT= A bsnmpd module allowing creation of counters from log files
GNU_CONFIGURE= yes
+OPTIONS= PCRE "Use PCRE instead of the default regex library" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --enable-pcre
+.else
+CONFIGURE_ARGS+= --disable-pcre
+.endif
+
MAN1= sockin.1
MAN5= bsnmp-regex.conf.5
MAN8= bsnmp-regex.8