aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/chillispot
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-24 19:17:15 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-24 19:17:15 +0000
commit1fbac4ef386973b54d1558d0a75d3268266dcadf (patch)
tree4c597a46a01905b03e90365b160866152f5f1124 /net-mgmt/chillispot
parent4dd71b23f437e3da12805d237829767d5b305c9a (diff)
downloadports-1fbac4ef386973b54d1558d0a75d3268266dcadf.tar.gz
ports-1fbac4ef386973b54d1558d0a75d3268266dcadf.zip
- remove deprecated apache versions
- use USE_APACHE_RUN - convert to new options framework no bump since all options are off per default PR: ports/171007 Submitted by: ohauer Approved by: venture37@geeklan.co.uk (maintainer) per mail
Notes
Notes: svn path=/head/; revision=303097
Diffstat (limited to 'net-mgmt/chillispot')
-rw-r--r--net-mgmt/chillispot/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/net-mgmt/chillispot/Makefile b/net-mgmt/chillispot/Makefile
index 2b3e4ff9220f..ff1d88c18bd6 100644
--- a/net-mgmt/chillispot/Makefile
+++ b/net-mgmt/chillispot/Makefile
@@ -24,28 +24,24 @@ USE_RC_SUBR= chillispot
SUB_FILES= pkg-message installguide.txt
MAN8= chilli.8
-OPTIONS= RAW "Latest Release Of Apache & mySQL" Off \
- MATURE "Stable Releases of Apache with mod_ssl & MySQL" Off \
- FREE "freeRADIUS" Off \
- OPENR "openradius" Off
+OPTIONS_DEFINE= APACHE RADIUS
+OPTIONS_SINGLE= RADIUS
+OPTIONS_SINGLE_RADIUS= FREERADIUS OPENRADIUS
-.include <bsd.port.pre.mk>
+FREERADIUS_DESC=depend on FreeRADIUS
+OPENRADIUS_DESC=depend on OpenRADIUS
-.if defined(WITH_RAW)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache20 \
- ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql50-server
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_MATURE)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13-modssl \
- ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql41-server
+.if ${PORT_OPTIONS:MAPACHE}
+USE_APACHE_RUN= 22+
.endif
-.if defined(WITH_FREE)
+.if ${PORT_OPTIONS:MFREERADIUS}
RUN_DEPENDS+= radiusd:${PORTSDIR}/net/freeradius
.endif
-.if defined(WITH_OPENR)
+.if ${PORT_OPTIONS:MOPENRADIUS}
RUN_DEPENDS+= radiusd:${PORTSDIR}/net/openradius
.endif
@@ -62,4 +58,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>