aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/choparp
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-06-07 13:13:53 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-06-07 13:13:53 +0000
commit3dbe47d57049004a6b00bb61ca1327976b984f87 (patch)
tree4665c13f87a5667b98b74913c685386e24948213 /net-mgmt/choparp
parentefe4dab2e5ee34135a07f13e0dce1d10eb0acc35 (diff)
downloadports-3dbe47d57049004a6b00bb61ca1327976b984f87.tar.gz
ports-3dbe47d57049004a6b00bb61ca1327976b984f87.zip
- Regenerate patches with make makepatch to silence portlint
- Take maintainership Sponsored by: Netgate
Notes
Notes: svn path=/head/; revision=388697
Diffstat (limited to 'net-mgmt/choparp')
-rw-r--r--net-mgmt/choparp/Makefile2
-rw-r--r--net-mgmt/choparp/files/patch-Makefile4
-rw-r--r--net-mgmt/choparp/files/patch-choparp.810
-rw-r--r--net-mgmt/choparp/files/patch-choparp.c20
4 files changed, 18 insertions, 18 deletions
diff --git a/net-mgmt/choparp/Makefile b/net-mgmt/choparp/Makefile
index ba32d1ae4991..44fed991c178 100644
--- a/net-mgmt/choparp/Makefile
+++ b/net-mgmt/choparp/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= garga@FreeBSD.org
COMMENT= Simple proxy arp daemon
LICENSE= BSD3CLAUSE
diff --git a/net-mgmt/choparp/files/patch-Makefile b/net-mgmt/choparp/files/patch-Makefile
index a22f22b7a086..4b605bc8368b 100644
--- a/net-mgmt/choparp/files/patch-Makefile
+++ b/net-mgmt/choparp/files/patch-Makefile
@@ -1,5 +1,5 @@
---- /dev/null Tue Oct 7 23:33:35 1997
-+++ Makefile Tue Oct 7 23:42:51 1997
+--- Makefile.orig 2015-06-07 13:12:33 UTC
++++ Makefile
@@ -0,0 +1,11 @@
+PROG= choparp
+MAN8= choparp.8
diff --git a/net-mgmt/choparp/files/patch-choparp.8 b/net-mgmt/choparp/files/patch-choparp.8
index f7424511948c..be9f352272b4 100644
--- a/net-mgmt/choparp/files/patch-choparp.8
+++ b/net-mgmt/choparp/files/patch-choparp.8
@@ -1,5 +1,5 @@
---- choparp.8.orig 2002-11-08 07:36:03.000000000 +0900
-+++ choparp.8 2010-05-04 20:39:28.291199414 +0900
+--- choparp.8.orig 2002-11-07 22:36:03 UTC
++++ choparp.8
@@ -34,7 +34,8 @@
.Nm choparp
.Nd cheap and omitted proxy ARP
@@ -19,7 +19,7 @@
It watches ARP request packets visible on the interface specified by argument
.Ar if_name ,
and sends proxy ARP reply to the sender if the ARP request queries the
-@@ -52,7 +53,7 @@
+@@ -52,7 +53,7 @@ for the network specified by
.Ar net_addr Ns / Ar net_mask .
.Pp
.Ar mac_addr
@@ -28,7 +28,7 @@
It is normally the address of
.Ar if_name .
The format of
-@@ -72,7 +73,7 @@
+@@ -72,7 +73,7 @@ or be a 32 bit hexadecimal value startin
.Dq 0x
.Pq for example Ad 0x858a0186 .
.Ar net_mask
@@ -37,7 +37,7 @@
or alternatively as a mask length. The following address specifications
are therefore equivalent:
.Bl -item -offset indent
-@@ -89,6 +90,16 @@
+@@ -89,6 +90,16 @@ Addresses can be
.Em excluded
by preceding them with
.Fl
diff --git a/net-mgmt/choparp/files/patch-choparp.c b/net-mgmt/choparp/files/patch-choparp.c
index dce53bc45021..1d28ecdb38c1 100644
--- a/net-mgmt/choparp/files/patch-choparp.c
+++ b/net-mgmt/choparp/files/patch-choparp.c
@@ -1,5 +1,5 @@
---- choparp.c.orig 2002-11-08 07:36:03.000000000 +0900
-+++ choparp.c 2010-05-04 20:39:28.279310506 +0900
+--- choparp.c.orig 2002-11-07 22:36:03 UTC
++++ choparp.c
@@ -42,6 +42,7 @@
#include <string.h>
#include <sys/types.h>
@@ -8,7 +8,7 @@
#include <sys/time.h>
#include <sys/ioctl.h>
#include <net/bpf.h>
-@@ -75,6 +76,7 @@
+@@ -75,6 +76,7 @@ struct cidr {
struct cidr *targets = NULL, *excludes = NULL;
u_char target_mac[ETHER_ADDR_LEN]; /* target MAC address */
@@ -16,7 +16,7 @@
/*
ARP filter program
-@@ -239,6 +241,16 @@
+@@ -239,6 +241,16 @@ checkarp(char *arpbuf){
fprintf(stderr,"checkarp: WARNING: received unknown type ARP request.\n");
return(0);
}
@@ -33,7 +33,7 @@
target_ip = ntohl(*(u_int32_t *)(arp->arp_tpa));
return match(target_ip, targets) && !match(target_ip, excludes);
}
-@@ -280,13 +292,22 @@
+@@ -280,13 +292,22 @@ loop(int fd, char *buf, size_t buflen){
char *rframe;
char *sframe;
size_t frame_len;
@@ -60,7 +60,7 @@
if (r < 0) {
if (errno == EINTR)
-@@ -295,7 +316,7 @@
+@@ -295,7 +316,7 @@ loop(int fd, char *buf, size_t buflen){
return;
}
@@ -69,7 +69,7 @@
if (rlen < 0) {
if (errno == EINTR)
continue;
-@@ -307,7 +328,7 @@
+@@ -307,7 +328,7 @@ loop(int fd, char *buf, size_t buflen){
while((rframe = getarp(p, rlen, &nextp, &nextlen)) != NULL){
if (checkarp(rframe)){
sframe = gen_arpreply(rframe, &frame_len);
@@ -78,7 +78,7 @@
}
p = nextp;
rlen = nextlen;
-@@ -362,13 +383,13 @@
+@@ -362,13 +383,13 @@ atoip(char *buf, u_int32_t *ip_addr){
void
usage(void){
@@ -94,7 +94,7 @@
char *buf, *ifname;
struct cidr **targets_tail = &targets, **excludes_tail = &excludes;
#define APPEND(LIST,ADDR,MASK) \
-@@ -381,13 +402,24 @@
+@@ -381,13 +402,24 @@ main(int argc, char **argv){
} while (0)
size_t buflen;
@@ -123,7 +123,7 @@
while (argc > 0) {
u_int32_t addr, mask = ~0;
-@@ -437,6 +469,9 @@
+@@ -437,6 +469,9 @@ main(int argc, char **argv){
#endif
if ((fd = openbpf(ifname, &buf, &buflen)) < 0)
return(-1);