aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-12-29 18:48:03 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-12-29 18:48:03 +0000
commit0563d9264f8fdece6dc5669b0ec4b55a58130e30 (patch)
treea3f038305cb02da2051498fb845243eb4bb4555e /net-mgmt/collectd5
parentba36dddf05dcc583ceed41890c9c9e1c8eaa1d01 (diff)
downloadports-0563d9264f8fdece6dc5669b0ec4b55a58130e30.tar.gz
ports-0563d9264f8fdece6dc5669b0ec4b55a58130e30.zip
net-mgmt/collectd5: finish option helpers conversion
- Switch PERL and PYTHON options over and drop the bsd.port.options.mk include following r404759's update to bsd.options.mk PR: 204220 Submitted by: Krzysztof <ports@bsdserwis.com> (maintainer)
Notes
Notes: svn path=/head/; revision=404774
Diffstat (limited to 'net-mgmt/collectd5')
-rw-r--r--net-mgmt/collectd5/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index c5ec59229759..fcf8e3911523 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -186,6 +186,10 @@ OPENLDAP_USE= openldap=yes
OPENLDAP_CONFIGURE_ENABLE= openldap
OPENLDAP_CONFIGURE_WITH= libldap=${LOCALBASE}
+PERL_USES= perl5
+PERL_CONFIGURE_ENABLE= perl
+PERL_CONFIGURE_WITH= perl=${PERL} perl-bindings
+
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= postgresql
PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE} libpq
@@ -197,6 +201,10 @@ PING_LIB_DEPENDS= liboping.so:${PORTSDIR}/net/liboping
PING_CONFIGURE_ENABLE= ping
PING_CONFIGURE_WITH= liboping=${LOCALBASE}
+PYTHON_USES= python:2
+PYTHON_CONFIGURE_ENABLE= python
+PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
+
RABBITMQ_LIB_DEPENDS= librabbitmq.so:${PORTSDIR}/net/rabbitmq-c
RABBITMQ_CONFIGURE_ENABLE= rabbitmq
RABBITMQ_CONFIGURE_WITH= librabbitmq=${LOCALBASE}
@@ -313,26 +321,6 @@ CONFIGURE_ARGS+=--enable-aggregation \
INSTALL_TARGET= install-strip
SHEBANG_FILES= contrib/collection.cgi
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perl=${PERL} --with-perl-bindings --enable-perl
-PLIST_SUB+= PERL=""
-.else
-CONFIGURE_ARGS+=--without-perl --without-perl-bindings --disable-perl
-PLIST_SUB+= PERL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python:2
-CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} --enable-python
-PLIST_SUB+= PYTHON=""
-.else
-CONFIGURE_ARGS+=--without-python --disable-python
-PLIST_SUB+= PYTHON="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/-Werror//' \
${WRKSRC}/configure.ac ${WRKSRC}/src/Makefile.am \