aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-10-05 15:33:51 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-10-05 15:33:51 +0000
commit5cc571f2769e100f9fce8d49885a035aa7216d6e (patch)
treeafc07a6fcc2f428f297625bdeb23be6f9c9528ff /net-mgmt/collectd
parent32c60786a0f7c981a4284ff8af372b980aa39c58 (diff)
downloadports-5cc571f2769e100f9fce8d49885a035aa7216d6e.tar.gz
ports-5cc571f2769e100f9fce8d49885a035aa7216d6e.zip
Notes
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile14
-rw-r--r--net-mgmt/collectd/files/patch-configure.in43
2 files changed, 39 insertions, 18 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 49281aa7f5a2..578040e27bdc 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -14,10 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
-USES= gmake libtool
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf autoheader automake
-WANT_GNOME= yes
+USES= autoreconf gmake libtool
OPTIONS_DEFINE= CGI BIND DEBUG GCRYPT LIBVIRT
OPTIONS_GROUP= INPUT OUTPUT
@@ -433,17 +431,15 @@ CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
-AUTOTOOLSFILES= aclocal.m4
-
post-patch:
- @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
- -e 's|2.65|%%AUTOCONF_VERSION%%|g' \
- ${WRKSRC}/aclocal.m4
+ @${RM} -r ${WRKSRC}/libltdl
@${REINPLACE_CMD} \
-e 's;@prefix@/var/;/var/;' \
-e 's;/var/lib/;/var/db/;' \
${WRKSRC}/src/collectd.conf.in
- @${REINPLACE_CMD} -e '/\$$[(]mkinstalldirs)/d' ${WRKSRC}/Makefile.in \
+ @${REINPLACE_CMD} \
+ -e '/^ACLOCAL_AMFLAGS =/s;libltdl/m4;m4;' \
+ -e '/\$$[(]mkinstalldirs)/d' \
${WRKSRC}/Makefile.am
@${REINPLACE_CMD} \
-e 's;/etc/collection\.conf;${WWWDIR}/collection.conf;' \
diff --git a/net-mgmt/collectd/files/patch-configure.in b/net-mgmt/collectd/files/patch-configure.in
index b5d76f9d540a..339c29f78f3c 100644
--- a/net-mgmt/collectd/files/patch-configure.in
+++ b/net-mgmt/collectd/files/patch-configure.in
@@ -1,6 +1,31 @@
---- configure.in.orig 2012-11-11 11:43:05.000000000 +0100
-+++ configure.in 2012-12-30 23:49:30.000000000 +0100
-@@ -67,6 +67,9 @@
+--- configure.in.orig 2013-04-08 06:26:17 UTC
++++ configure.in
+@@ -2,13 +2,13 @@
+ AC_INIT(collectd, m4_esyscmd(./version-gen.sh))
+ AC_CONFIG_SRCDIR(src/collectd.c)
+ AC_CONFIG_HEADERS(src/config.h)
+-AC_CONFIG_AUX_DIR([libltdl/config])
++AC_CONFIG_AUX_DIR([config])
+
+ m4_ifdef([LT_PACKAGE_VERSION],
+ # libtool >= 2.2
+ [
+ LT_CONFIG_LTDL_DIR([libltdl])
+- LT_INIT([dlopen])
++ LT_INIT([dlopen disable-static])
+ LTDL_INIT([convenience])
+ AC_DEFINE(LIBTOOL_VERSION, 2, [Define to used libtool version.])
+ ]
+@@ -42,8 +42,6 @@
+ AM_PROG_CC_C_O
+ AM_CONDITIONAL(COMPILER_IS_GCC, test "x$GCC" = "xyes")
+
+-AC_DISABLE_STATIC
+-AC_PROG_LIBTOOL
+ AC_PROG_LEX
+ AC_PROG_YACC
+ PKG_PROG_PKG_CONFIG
+@@ -67,6 +65,9 @@
*openbsd*)
ac_system="OpenBSD"
;;
@@ -10,7 +35,7 @@
*aix*)
AC_DEFINE([KERNEL_AIX], 1, [True if program is to be compiled for a AIX kernel])
ac_system="AIX"
-@@ -98,7 +101,7 @@
+@@ -98,7 +99,7 @@
fi
# Where to install .pc files.
@@ -19,7 +44,7 @@
AC_SUBST(pkgconfigdir)
# Check for standards compliance mode
-@@ -1200,6 +1203,8 @@
+@@ -1200,6 +1201,8 @@
then
AC_DEFINE(HAVE_LIBKSTAT, 1,
[Define to 1 if you have the 'kstat' library (-lkstat)])
@@ -28,7 +53,7 @@
fi
AM_CONDITIONAL(BUILD_WITH_LIBKSTAT, test "x$with_kstat" = "xyes")
AM_CONDITIONAL(BUILD_WITH_LIBDEVINFO, test "x$with_devinfo" = "xyes")
-@@ -1562,9 +1567,6 @@
+@@ -1562,9 +1565,6 @@
[with_libgcrypt="yes"],
[with_libgcrypt="no (symbol gcry_md_hash_buffer not found)"])
@@ -38,7 +63,7 @@
fi
CPPFLAGS="$SAVE_CPPFLAGS"
-@@ -3059,7 +3061,7 @@
+@@ -3056,7 +3056,7 @@
if test "x$with_python" = "xyes"
then
AC_MSG_CHECKING([for Python LIBS])
@@ -47,7 +72,7 @@
python_config_status=$?
if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -3074,7 +3076,7 @@
+@@ -3071,7 +3071,7 @@
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
@@ -56,7 +81,7 @@
AC_CHECK_FUNC(PyObject_CallFunction,
[with_python="yes"],
-@@ -4171,6 +4173,12 @@
+@@ -4168,6 +4168,12 @@
plugin_zfs_arc="yes"
fi