aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2014-05-12 22:07:39 +0000
committerTim Bishop <tdb@FreeBSD.org>2014-05-12 22:07:39 +0000
commitde3932175cd21dc59bf9d3f21988ca80e44ef89e (patch)
tree968d82690d4bfa2d159b2c7a88db93f21807d7d7 /net-mgmt/collectd
parent620812da659057f643d11bfce4b669319d1d9150 (diff)
downloadports-de3932175cd21dc59bf9d3f21988ca80e44ef89e.tar.gz
ports-de3932175cd21dc59bf9d3f21988ca80e44ef89e.zip
Notes
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile4
-rw-r--r--net-mgmt/collectd/files/patch-src__collectd.c11
-rw-r--r--net-mgmt/collectd/files/patch-src__disk.c12
3 files changed, 25 insertions, 2 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 0bea3eea7e95..208ce309b476 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 4.10.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -252,7 +252,7 @@ PLIST_SUB+= NUTUPS="@comment "
.if ${PORT_OPTIONS:MINTERFACE}
USES+= pkgconfig
CONFIGURE_ARGS+=--enable-interface
-LIB_DEPENDS+= statgrab:${PORTSDIR}/devel/libstatgrab
+LIB_DEPENDS+= libstatgrab.so:${PORTSDIR}/devel/libstatgrab
PLIST_SUB+= INTERFACE=""
CONFIGURE_ENV+= LIBS="`pkg-config --libs libstatgrab`"
.else
diff --git a/net-mgmt/collectd/files/patch-src__collectd.c b/net-mgmt/collectd/files/patch-src__collectd.c
new file mode 100644
index 000000000000..976c2d8c4735
--- /dev/null
+++ b/net-mgmt/collectd/files/patch-src__collectd.c
@@ -0,0 +1,11 @@
+--- ./src/collectd.c.orig 2013-11-23 22:04:05.130103822 +0000
++++ ./src/collectd.c 2013-11-23 22:04:25.627104708 +0000
+@@ -294,7 +294,7 @@
+ #endif
+
+ #if HAVE_LIBSTATGRAB
+- if (sg_init ())
++ if (sg_init (0))
+ {
+ ERROR ("sg_init: %s", sg_str_error (sg_get_error ()));
+ return (-1);
diff --git a/net-mgmt/collectd/files/patch-src__disk.c b/net-mgmt/collectd/files/patch-src__disk.c
new file mode 100644
index 000000000000..5f144e50a241
--- /dev/null
+++ b/net-mgmt/collectd/files/patch-src__disk.c
@@ -0,0 +1,12 @@
+--- ./src/disk.c.orig 2013-11-23 22:36:13.757103756 +0000
++++ ./src/disk.c 2013-11-23 22:36:15.058103844 +0000
+@@ -691,7 +691,8 @@
+
+ #elif defined(HAVE_LIBSTATGRAB)
+ sg_disk_io_stats *ds;
+- int disks, counter;
++ size_t disks;
++ int counter;
+ char name[DATA_MAX_NAME_LEN];
+
+ if ((ds = sg_get_disk_io_stats(&disks)) == NULL)