aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/docsis
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-04-15 00:18:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-04-15 00:18:30 +0000
commit5c3d3ef711444bdcebb00c957326b275c68f6fec (patch)
tree28f1045b904c81baa828889d65dc1b68341f82aa /net-mgmt/docsis
parente022a4f3e2df4d33e23b6c27a12b515d0ebb3399 (diff)
downloadports-5c3d3ef711444bdcebb00c957326b275c68f6fec.tar.gz
ports-5c3d3ef711444bdcebb00c957326b275c68f6fec.zip
Notes
Diffstat (limited to 'net-mgmt/docsis')
-rw-r--r--net-mgmt/docsis/Makefile8
-rw-r--r--net-mgmt/docsis/distinfo2
-rw-r--r--net-mgmt/docsis/files/patch-Makefile32
-rw-r--r--net-mgmt/docsis/files/patch-docsis_decode.c11
-rw-r--r--net-mgmt/docsis/files/patch-docsis_snmp.c19
-rw-r--r--net-mgmt/docsis/pkg-plist28
6 files changed, 51 insertions, 49 deletions
diff --git a/net-mgmt/docsis/Makefile b/net-mgmt/docsis/Makefile
index af19722aa93c..eb805b18831f 100644
--- a/net-mgmt/docsis/Makefile
+++ b/net-mgmt/docsis/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= docsis
-PORTVERSION= 0.7.5
+PORTVERSION= 0.8.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-RELEASE
EXTRACT_SUFX= .tgz
-MAINTAINER= jflemer@acm.jhu.edu
+MAINTAINER= jflemer@alum.rpi.edu
COMMENT= DOCSIS(tm) binary configuration file encoder/decoder
-LIB_DEPENDS= snmp.4:${PORTSDIR}/net/net-snmp4
+LIB_DEPENDS= netsnmp:${PORTSDIR}/net/net-snmp
USE_OPENSSL= yes
USE_BISON= yes
+ALL_TARGET= docsis
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/docsis ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
diff --git a/net-mgmt/docsis/distinfo b/net-mgmt/docsis/distinfo
index 19d2a9fd1a38..1361ad6dc2ef 100644
--- a/net-mgmt/docsis/distinfo
+++ b/net-mgmt/docsis/distinfo
@@ -1 +1 @@
-MD5 (docsis-0.7.5-RELEASE.tgz) = 9cd8250b2c7e9f764db534e5f7aaca7d
+MD5 (docsis-0.8.2-RELEASE.tgz) = 595fbed678834bc9f60bc6d5bbe847d8
diff --git a/net-mgmt/docsis/files/patch-Makefile b/net-mgmt/docsis/files/patch-Makefile
index b57482e32afc..986b74873507 100644
--- a/net-mgmt/docsis/files/patch-Makefile
+++ b/net-mgmt/docsis/files/patch-Makefile
@@ -1,20 +1,24 @@
---- Makefile.orig Wed Feb 13 14:09:52 2002
-+++ Makefile Thu Jul 18 00:11:49 2002
-@@ -1,4 +1,3 @@
+
+$FreeBSD$
+
+--- Makefile.orig Tue Feb 11 15:36:39 2003
++++ Makefile Thu Feb 27 19:16:03 2003
+@@ -1,6 +1,6 @@
+ # Makefile for "docsis" program.
+ #
-CC = gcc
++#CC = gcc
DEFS = -DYY_NO_UNPUT -DDEBUG
#
- # We assume ucd-snmp is installed in /opt/ucd-snmp-4.2. If not, replace with
-@@ -7,8 +6,10 @@
+ # We assume net-snmp is installed in /opt/net-snmp. If not, replace with
+@@ -8,8 +8,8 @@
+ # -lnetsnmp is NET-SNMP
# -lcrypto is OpenSSL.
#
- # CFLAGS = -g -Wall -I/usr/local/include
--CFLAGS = -g -Wall -I/opt/ucd-snmp-4.2/include
--LIBS = -L/opt/ucd-snmp-4.2/lib -lsnmp -lcrypto -lnsl -lfl -lm
-+CFLAGS += -g -Wall -I${LOCALBASE}/include
-+LIBS += -L${LOCALBASE}/lib -lsnmp -lcrypto -lfl -lm
-+
-+all: docsis
+-CFLAGS = -g -Wall -I/opt/net-snmp/include
+-LIBS = -L/opt/net-snmp/lib -lnetsnmp -lcrypto -lnsl -lfl -lm
++CFLAGS += -I${PREFIX}/include -I${OPENSSLINC}
++LIBS = -L${PREFIX}/lib -L${OPENSSLLIB} -lnetsnmp -lcrypto -lfl -lm
- docsis: Makefile docsis_decode.o docsis_yy.o docsis_main.o md5.o hmac_md5.o docsis_snmp.o ethermac.h ethermac.o version.h docsis_encode.o
- $(CC) $(CFLAGS) $(DEFS) -g -o docsis docsis_main.o docsis_encode.o docsis_decode.o docsis_yy.o md5.o hmac_md5.o docsis_snmp.o ethermac.o $(LIBS)
+ # If you installed NET-SNMP in /usr/local, uncomment the following two lines:
+ # CFLAGS = -g -Wall -I/usr/local/include
diff --git a/net-mgmt/docsis/files/patch-docsis_decode.c b/net-mgmt/docsis/files/patch-docsis_decode.c
deleted file mode 100644
index ea2184c0fa84..000000000000
--- a/net-mgmt/docsis/files/patch-docsis_decode.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- docsis_decode.c.orig Fri Jul 5 14:54:11 2002
-+++ docsis_decode.c Fri Jul 5 14:55:31 2002
-@@ -47,7 +47,7 @@
- memset( &helper, 0,sizeof(unsigned int));
- memcpy( &helper, tlvbuf+2, sizeof(unsigned int));
-
-- printf ( "%s %u;\n", sym->sym_ident, ntohl(helper));
-+ printf ( "%s %u;\n", sym->sym_ident, (unsigned int)ntohl(helper));
- }
-
- void decode_ushort (unsigned char *tlvbuf, symbol_type *sym)
diff --git a/net-mgmt/docsis/files/patch-docsis_snmp.c b/net-mgmt/docsis/files/patch-docsis_snmp.c
index d7c6b08942fc..bbf8b1e8877b 100644
--- a/net-mgmt/docsis/files/patch-docsis_snmp.c
+++ b/net-mgmt/docsis/files/patch-docsis_snmp.c
@@ -1,10 +1,13 @@
---- docsis_snmp.c.orig Fri Jul 5 14:56:11 2002
-+++ docsis_snmp.c Fri Jul 5 14:56:53 2002
-@@ -165,6 +165,7 @@
- if (snmp_set_var_objid(vp, objid, vp->name_length))
- return -1;
+
+$FreeBSD$
+
+--- docsis_snmp.c.orig Tue Feb 11 16:36:30 2003
++++ docsis_snmp.c Thu Feb 27 19:17:23 2003
+@@ -206,6 +206,7 @@
+ static char outbuf[1024];
+ char *cp;
+ badtype = 0;
- len = PACKET_LENGTH;
- switch((short)vp->type){
- case ASN_INTEGER:
+ memset (outbuf, 0, 1024);
+
+ vp = (struct variable_list *) malloc (sizeof (struct variable_list));
diff --git a/net-mgmt/docsis/pkg-plist b/net-mgmt/docsis/pkg-plist
index 2010eefbe3a8..7f8b2607a04a 100644
--- a/net-mgmt/docsis/pkg-plist
+++ b/net-mgmt/docsis/pkg-plist
@@ -1,18 +1,22 @@
bin/docsis
+share/examples/docsis/docsis1.0_2class_non-rfc2669.cfg
+share/examples/docsis/docsis1.0_2class_rfc2669.cfg
+share/examples/docsis/docsis1.0_basic.cfg
+share/examples/docsis/docsis1.0_basic_bpi.cfg
+share/examples/docsis/docsis1.0_basic_upgrade.cfg
+share/examples/docsis/docsis1.0_example.cfg
+share/examples/docsis/docsis1.0_filters2_oidnum.cfg
+share/examples/docsis/docsis1.0_filters2_oidtext.cfg
+share/examples/docsis/docsis1.0_filters_NmAccess.cfg
+share/examples/docsis/docsis1.0_filters_oidnum.cfg
+share/examples/docsis/docsis1.0_filters_oidtext.cfg
+share/examples/docsis/docsis1.1_classifiers.cfg
+share/examples/docsis/docsis1.1_classifiers2.cfg
+share/examples/docsis/docsis1.1_simple.cfg
+share/examples/docsis/docsis1.1_stress_test.cfg
share/examples/docsis/docsis20.cfg
share/examples/docsis/docsis20_no_snmp.cfg
-share/examples/docsis/example-non-rfc2669.cfg
-share/examples/docsis/example.cfg
-share/examples/docsis/hoof-lab.cfg
-share/examples/docsis/hoof-lab1.cfg
share/examples/docsis/keyfile
-share/examples/docsis/modem-b.cfg
-share/examples/docsis/modem-oid.cfg
-share/examples/docsis/modem-text.cfg
-share/examples/docsis/modem.cfg
-share/examples/docsis/modem1.cfg
-share/examples/docsis/rolab-oid.cfg
-share/examples/docsis/rolab-text.cfg
-share/examples/docsis/snmp20.cfg
+share/examples/docsis/packetcable_mta.cfg
share/examples/docsis/testkey.key
@dirrm share/examples/docsis