aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/driftnet
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-24 18:19:23 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-24 18:19:23 +0000
commitb2053786ce53da051a1e5756f7cbe55aa50180dc (patch)
treed22ee47f309af4f98bfeb96fd87674677e46b434 /net-mgmt/driftnet
parent266f7e411b0de527c9763fb14af2aa0e226051cc (diff)
downloadports-b2053786ce53da051a1e5756f7cbe55aa50180dc.tar.gz
ports-b2053786ce53da051a1e5756f7cbe55aa50180dc.zip
4 ports categories: Remove $PTHREAD_LIBS
Categories: www, ftp, net-im, net-mgmt approved by: PTHREAD blanket
Notes
Notes: svn path=/head/; revision=382150
Diffstat (limited to 'net-mgmt/driftnet')
-rw-r--r--net-mgmt/driftnet/Makefile2
-rw-r--r--net-mgmt/driftnet/files/patch-Makefile13
2 files changed, 6 insertions, 9 deletions
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
index 9faf47d3aaa8..0ed4c5fe39c5 100644
--- a/net-mgmt/driftnet/Makefile
+++ b/net-mgmt/driftnet/Makefile
@@ -22,8 +22,6 @@ USE_GNOME= gtk12
USES= gmake
ALL_TARGET= default
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-
PLIST_FILES= bin/driftnet man/man1/driftnet.1.gz
do-install:
diff --git a/net-mgmt/driftnet/files/patch-Makefile b/net-mgmt/driftnet/files/patch-Makefile
index fefd985d3e20..bdcae0ef83e4 100644
--- a/net-mgmt/driftnet/files/patch-Makefile
+++ b/net-mgmt/driftnet/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jul 9 12:26:41 2002
-+++ Makefile Sat Sep 28 22:19:21 2002
+--- Makefile.orig 2002-07-09 19:26:41 UTC
++++ Makefile
@@ -16,23 +16,23 @@
#CC = gcc
@@ -19,19 +19,18 @@
+#CFLAGS += -D_BSD_SOURCE
# We always need the pcap and pthread libraries.
--LDLIBS += -lpcap -lpthread
-+LDLIBS += -lpcap ${PTHREAD_LIBS}
+ LDLIBS += -lpcap -lpthread
# Optional C compiler and linker flags. Typical driftnet builds have support
# for displaying captured images in an X window, and need the following flags:
-CFLAGS += `gtk-config --cflags`
-LDLIBS += -ljpeg -lungif `gtk-config --libs`
-+CFLAGS += ${PTHREAD_CFLAGS} `${GTK_CONFIG} --cflags`
++CFLAGS += `${GTK_CONFIG} --cflags`
+LDLIBS += -ljpeg -lgif `${GTK_CONFIG} --libs`
# Alternatively, you can build a version of driftnet which can only be used
# in `adjunct' mode as the back end for some other image-processing program. To
-@@ -43,7 +43,7 @@
+@@ -43,7 +43,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# On systems with a C99 compiler, driftnet will use <stdint.h> for the
# definitions of types such as uint8_t. On other systems like Solaris, these
# are in <sys/types.h>, and you should uncomment this line.
@@ -40,7 +39,7 @@
# On Solaris, it is necessary to link against -lposix4 for the definition of
# nanosleep; uncomment the below.
-@@ -51,7 +51,7 @@
+@@ -51,7 +51,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# added 20020604 edobbs
# On BSD systems, may need to use /usr/local/include