aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ehnt
diff options
context:
space:
mode:
authorDmitry Morozovsky <marck@FreeBSD.org>2013-10-16 13:03:53 +0000
committerDmitry Morozovsky <marck@FreeBSD.org>2013-10-16 13:03:53 +0000
commitf60b741a66bf9c04510cdee5c7630218f1b7fa9b (patch)
tree36d23b709309cc320a3d604c2d94108fa0d669df /net-mgmt/ehnt
parent57d07bef8d4430fd2db9a4183d3d728fc7ad68d7 (diff)
downloadports-f60b741a66bf9c04510cdee5c7630218f1b7fa9b.tar.gz
ports-f60b741a66bf9c04510cdee5c7630218f1b7fa9b.zip
Actually do stage support
PR: 183008 Submitted by: marino Pointy hat to: marck
Notes
Notes: svn path=/head/; revision=330509
Diffstat (limited to 'net-mgmt/ehnt')
-rw-r--r--net-mgmt/ehnt/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-mgmt/ehnt/Makefile b/net-mgmt/ehnt/Makefile
index b71c06e2e1c5..b816f246fa57 100644
--- a/net-mgmt/ehnt/Makefile
+++ b/net-mgmt/ehnt/Makefile
@@ -15,6 +15,7 @@ PLIST_FILES= bin/ehnt etc/rc.d/ehntserv.sh.sample \
PLIST_DIRS+= share/ehnt
PORTDOCS= README
+STPREFIX= ${STAGEDIR}${PREFIX}
MAN1= ehnt.1
MAN8= ehntserv.8
@@ -23,16 +24,16 @@ post-extract:
${TOUCH} ${WRKSRC}/asnc.txt
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ehnt ${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/ehntserv ${PREFIX}/sbin/
- ${INSTALL_SCRIPT} ${FILESDIR}/ehntserv.sh.sample ${PREFIX}/etc/rc.d/
- ${INSTALL_MAN} ${WRKSRC}/ehnt.1 ${PREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/ehntserv.8 ${PREFIX}/man/man8/
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${DATADIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/ehnt ${STPREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/ehntserv ${STPREFIX}/sbin/
+ ${INSTALL_SCRIPT} ${FILESDIR}/ehntserv.sh.sample ${STPREFIX}/etc/rc.d/
+ ${INSTALL_MAN} ${WRKSRC}/ehnt.1 ${STPREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/ehntserv.8 ${STPREFIX}/man/man8/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${STAGEDIR}${DATADIR}/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>