aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/etherape
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-30 20:30:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-30 20:30:39 +0000
commit0d554e8e95ae87358367f7e2e2f4d4c27d782eab (patch)
treeb4d3f5b7552221e9abb92f25cbeb46e22be073aa /net-mgmt/etherape
parent04b519b5779304fa52454ae0dc6177b86d17e406 (diff)
downloadports-0d554e8e95ae87358367f7e2e2f4d4c27d782eab.tar.gz
ports-0d554e8e95ae87358367f7e2e2f4d4c27d782eab.zip
- Update to 0.9.6
Approved by: Samy Al Bahra <sbahra@kerneled.org> (maintainer)
Notes
Notes: svn path=/head/; revision=164003
Diffstat (limited to 'net-mgmt/etherape')
-rw-r--r--net-mgmt/etherape/Makefile9
-rw-r--r--net-mgmt/etherape/distinfo6
-rw-r--r--net-mgmt/etherape/files/patch-capture.c20
-rw-r--r--net-mgmt/etherape/files/patch-resolv.c11
-rw-r--r--net-mgmt/etherape/files/patch-src__capture.c20
-rw-r--r--net-mgmt/etherape/files/patch-src__globals.h11
-rw-r--r--net-mgmt/etherape/files/patch-src__main.c12
-rw-r--r--net-mgmt/etherape/files/patch-thread_resolve.c23
-rw-r--r--net-mgmt/etherape/pkg-plist25
9 files changed, 83 insertions, 54 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index 5df3fab2fa69..c7b1436d2097 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= etherape
-PORTVERSION= 0.9.1
-PORTREVISION= 8
+PORTVERSION= 0.9.6
CATEGORIES= net-mgmt gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,13 +15,17 @@ MAINTAINER= sbahra@kerneled.org
COMMENT= A graphical network traffic visualization tool for gnome
USE_GETTEXT= yes
-USE_GNOME= libglade2 libgnomeui
+USE_GNOME= libglade2 libgnomeui gnomehack
USE_GMAKE= yes
USE_X_PREFIX= yes
+INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= etherape.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(datadir)/omf|$$(prefix)/share/gnome/omf|g' ${WRKSRC}/doc/C/Makefile.in
+
.include <bsd.port.mk>
diff --git a/net-mgmt/etherape/distinfo b/net-mgmt/etherape/distinfo
index 48eb67f659b8..0e9b917329cd 100644
--- a/net-mgmt/etherape/distinfo
+++ b/net-mgmt/etherape/distinfo
@@ -1,3 +1,3 @@
-MD5 (etherape-0.9.1.tar.gz) = e38732c1bf8c451a1ff312086828e40b
-SHA256 (etherape-0.9.1.tar.gz) = 4a0bd3de85fa045b4fcb3bb852524471b4c8dcac8fb7a4356ba1c8641cc2be6e
-SIZE (etherape-0.9.1.tar.gz) = 447092
+MD5 (etherape-0.9.6.tar.gz) = a6f2b27da7d25346b824c42762ada61f
+SHA256 (etherape-0.9.6.tar.gz) = ab4e2f4dc90e2bccbf72f3bc750df4ea3c234fdbc31a85b640107f5b5c5e47fc
+SIZE (etherape-0.9.6.tar.gz) = 860413
diff --git a/net-mgmt/etherape/files/patch-capture.c b/net-mgmt/etherape/files/patch-capture.c
new file mode 100644
index 000000000000..4a7a0a44e28c
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-capture.c
@@ -0,0 +1,20 @@
+--- src/capture.c.orig Sat Apr 29 09:58:35 2006
++++ src/capture.c Mon May 29 01:14:23 2006
+@@ -464,10 +464,13 @@
+ return FALSE;
+ }
+
+- /* preparing protocol summary and nodes/links catalogs */
+- protocol_summary_open();
+- nodes_catalog_open();
+- links_catalog_open();
++ if (status != PAUSE)
++ {
++ /* preparing protocol summary and nodes/links catalogs */
++ protocol_summary_open();
++ nodes_catalog_open();
++ links_catalog_open();
++ }
+
+ /*
+ * See pause_capture for an explanation of why we don't always
diff --git a/net-mgmt/etherape/files/patch-resolv.c b/net-mgmt/etherape/files/patch-resolv.c
new file mode 100644
index 000000000000..4e062d403126
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-resolv.c
@@ -0,0 +1,11 @@
+--- src/resolv.c.orig Sat Apr 29 09:58:35 2006
++++ src/resolv.c Mon May 29 00:54:06 2006
+@@ -500,7 +500,7 @@
+ */
+ if (g_pethers_path == NULL)
+ {
+- g_strdup_printf (g_pethers_path, "%s/%s",
++ g_pethers_path = g_strdup_printf ("%s/%s",
+ get_home_dir (), EPATH_PERSONAL_ETHERS);
+ }
+
diff --git a/net-mgmt/etherape/files/patch-src__capture.c b/net-mgmt/etherape/files/patch-src__capture.c
deleted file mode 100644
index 6fb7bcd6ac45..000000000000
--- a/net-mgmt/etherape/files/patch-src__capture.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/capture.c.orig Sun Apr 6 10:45:41 2003
-+++ ./src/capture.c Sat Apr 29 11:48:08 2006
-@@ -527,7 +527,16 @@
- this_time.tv_usec = phdr.ts.tv_usec;
-
- diff = substract_times (this_time, last_time);
-- ms_to_next = diff.tv_sec * 1000 + diff.tv_usec / 1000;
-+
-+ if (pref.zero_delay)
-+ {
-+ ms_to_next = 0;
-+ }
-+ else
-+ {
-+ ms_to_next = diff.tv_sec * 1000 + diff.tv_usec / 1000;
-+ }
-+
-
- last_time = this_time;
-
diff --git a/net-mgmt/etherape/files/patch-src__globals.h b/net-mgmt/etherape/files/patch-src__globals.h
deleted file mode 100644
index 0c67aebdcf13..000000000000
--- a/net-mgmt/etherape/files/patch-src__globals.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/globals.h.orig Sun Apr 6 10:45:41 2003
-+++ ./src/globals.h Sat Apr 29 11:48:08 2006
-@@ -342,6 +342,8 @@
- gchar *interface; /* Network interface to listen to */
- gchar *filter; /* Pcap filter to be used */
-
-+ gboolean zero_delay; /* no delay processing tcpdump files */
-+
- }
- pref;
-
diff --git a/net-mgmt/etherape/files/patch-src__main.c b/net-mgmt/etherape/files/patch-src__main.c
deleted file mode 100644
index 06898039f77d..000000000000
--- a/net-mgmt/etherape/files/patch-src__main.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./src/main.c.orig Sun Apr 6 10:45:42 2003
-+++ ./src/main.c Sat Apr 29 11:48:08 2006
-@@ -60,6 +60,9 @@
- N_("set the node color"), N_("color")},
- {"text-color", 'T', POPT_ARG_STRING, &(pref.text_color), 0,
- N_("set the text color"), N_("color")},
-+ {"zero-delay", 'z', POPT_ARG_NONE, &(pref.zero_delay), 0,
-+ N_("zero delay for reading capture files [cli only]"), NULL},
-+
-
- POPT_AUTOHELP {NULL, 0, 0, NULL, 0}
- };
diff --git a/net-mgmt/etherape/files/patch-thread_resolve.c b/net-mgmt/etherape/files/patch-thread_resolve.c
new file mode 100644
index 000000000000..dd20e557e440
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-thread_resolve.c
@@ -0,0 +1,23 @@
+--- src/thread_resolve.c.orig Tue Apr 25 09:08:28 2006
++++ src/thread_resolve.c Mon May 29 00:37:45 2006
+@@ -167,6 +167,10 @@
+
+ pthread_mutex_unlock(&resolvemtx);
+ }
++
++ /* close mutex */
++ close_mutex();
++
+ return NULL;
+ }
+
+@@ -268,9 +272,6 @@
+ {
+ /* thread pool shutdown */
+ stop_threads();
+-
+- /* close mutex */
+- close_mutex();
+ }
+
+ /* returns 1 if the current dns implementation has a socket wich needs a select() */
diff --git a/net-mgmt/etherape/pkg-plist b/net-mgmt/etherape/pkg-plist
index abcac2c47158..b855233c199a 100644
--- a/net-mgmt/etherape/pkg-plist
+++ b/net-mgmt/etherape/pkg-plist
@@ -1,20 +1,35 @@
bin/etherape
etc/etherape/services
+share/applications/etherape.desktop
+%%DATADIR%%/doc/etherape/C/etherape.xml
+%%DATADIR%%/doc/etherape/C/figures/appmain.png
+%%DATADIR%%/doc/etherape/C/figures/capture_file_dlg.png
+%%DATADIR%%/doc/etherape/C/figures/color_select_dlg.png
+%%DATADIR%%/doc/etherape/C/figures/eth_toolbar.png
+%%DATADIR%%/doc/etherape/C/figures/link_info.png
+%%DATADIR%%/doc/etherape/C/figures/node_info.png
+%%DATADIR%%/doc/etherape/C/figures/pref_colors_dlg.png
+%%DATADIR%%/doc/etherape/C/figures/pref_diagram_dlg.png
+%%DATADIR%%/doc/etherape/C/figures/pref_timings_dlg.png
+%%DATADIR%%/doc/etherape/C/figures/proto_info.png
+%%DATADIR%%/doc/etherape/C/figures/protocol_edit_dlg.png
%%DATADIR%%/glade/etherape.glade2
%%DATADIR%%/glade/etherape.png
%%DATADIR%%/glade/pause.xpm
%%DATADIR%%/glade/play.xpm
%%DATADIR%%/glade/stop.xpm
-share/gnome/apps/Applications/etherape.desktop
-share/gnome/help/etherape/C/topic.dat
+share/gnome/omf/etherape/etherape-C.omf
share/locale/es/LC_MESSAGES/etherape.mo
share/locale/fr/LC_MESSAGES/etherape.mo
share/locale/nl/LC_MESSAGES/etherape.mo
share/locale/tr/LC_MESSAGES/etherape.mo
share/pixmaps/etherape.png
@dirrm etc/etherape
+@dirrm share/gnome/omf/etherape
@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/doc/etherape/C/figures
+@dirrm %%DATADIR%%/doc/etherape/C
+@dirrm %%DATADIR%%/doc/etherape
+@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
-@dirrm share/gnome/help/etherape/C/stylesheet-images
-@dirrm share/gnome/help/etherape/C
-@dirrm share/gnome/help/etherape
+@dirrmtry share/applications